projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
4702698
)
fix kexec-tools builds when libc != uClibc, strip quotes from KEXEC_TARGET_NAME confi...
author
Nicolas Thill
<nico@openwrt.org>
Tue, 7 Jul 2009 03:00:04 +0000
(
03:00
+0000)
committer
Nicolas Thill
<nico@openwrt.org>
Tue, 7 Jul 2009 03:00:04 +0000
(
03:00
+0000)
SVN-Revision: 16729
package/kexec-tools/Makefile
patch
|
blob
|
history
diff --git
a/package/kexec-tools/Makefile
b/package/kexec-tools/Makefile
index 910b6a25ae096603910c85d8cef0fadfe4310b5d..3f6137d3daca952694a515444614b318ddc30eae 100644
(file)
--- a/
package/kexec-tools/Makefile
+++ b/
package/kexec-tools/Makefile
@@
-35,9
+35,11
@@
define Package/kexec-tools/config
source "$(SOURCE)/kexec-config.in"
endef
+KEXEC_TARGET_NAME:=$(call qstrip,$(CONFIG_KEXEC_TOOLS_TARGET_NAME))-linux-$(TARGET_SUFFIX)
+
CONFIGURE_ARGS = \
- --target=$(
CONFIG_KEXEC_TOOLS_TARGET_NAME)-linux-$(TARGET_SUFFIX
) \
- --host=$(
GNU_TARGET_NAME)-uclibc
\
+ --target=$(
KEXEC_TARGET_NAME
) \
+ --host=$(
REAL_GNU_TARGET_NAME)
\
--build=$(GNU_HOST_NAME) \
--program-prefix="" \
--program-suffix="" \