MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
CPU_TYPE:=cortex-a9
-LINUX_VERSION:=3.10.49
+LINUX_VERSION:=3.14.14
include $(INCLUDE_DIR)/target.mk
+#endif /* CONFIG_OF */
--- a/include/linux/bcma/bcma.h
+++ b/include/linux/bcma/bcma.h
-@@ -322,6 +322,8 @@ struct bcma_bus {
+@@ -323,6 +323,8 @@ struct bcma_bus {
struct pci_dev *host_pci;
/* Pointer to the SDIO device (only for BCMA_HOSTTYPE_SDIO) */
struct sdio_func *host_sdio;
static int bcma_fill_sprom_with_fallback(struct bcma_bus *bus,
struct ssb_sprom *out)
{
-@@ -579,7 +621,14 @@ int bcma_sprom_get(struct bcma_bus *bus)
+@@ -580,7 +622,14 @@ int bcma_sprom_get(struct bcma_bus *bus)
u16 *sprom;
size_t sprom_sizes[] = { SSB_SPROMSIZE_WORDS_R4,
SSB_SPROMSIZE_WORDS_R10, };
arch/arm/mach-bcm/bcm_5301x.c | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
-diff --git a/arch/arm/mach-bcm/bcm_5301x.c b/arch/arm/mach-bcm/bcm_5301x.c
-index edff697..e349897 100644
--- a/arch/arm/mach-bcm/bcm_5301x.c
+++ b/arch/arm/mach-bcm/bcm_5301x.c
@@ -12,9 +12,26 @@
static int bcm5301x_abort_handler(unsigned long addr, unsigned int fsr,
struct pt_regs *regs)
{
-@@ -49,6 +66,19 @@ static void __init bcm5301x_dt_init(void)
+@@ -49,6 +66,19 @@ static void __init bcm5301x_dt_init(void
of_platform_populate(NULL, of_default_bus_match_table, NULL, NULL);
}
static const char __initconst *bcm5301x_dt_compat[] = {
"brcm,bcm4708",
NULL,
-@@ -57,5 +87,6 @@ static const char __initconst *bcm5301x_dt_compat[] = {
+@@ -57,5 +87,6 @@ static const char __initconst *bcm5301x_
DT_MACHINE_START(BCM5301X, "BCM5301X")
.init_early = bcm5301x_init_early,
.init_machine = bcm5301x_dt_init,
+ .restart = bcm5301x_restart,
.dt_compat = bcm5301x_dt_compat,
MACHINE_END
---
-1.8.4.5
-
ohci_addr = 0x18009000;
--- a/include/linux/bcma/bcma.h
+++ b/include/linux/bcma/bcma.h
-@@ -266,7 +266,7 @@ struct bcma_device {
+@@ -267,7 +267,7 @@ struct bcma_device {
u8 core_unit;
u32 addr;
default:
--- a/include/linux/bcma/bcma.h
+++ b/include/linux/bcma/bcma.h
-@@ -337,6 +337,7 @@ struct bcma_bus {
+@@ -338,6 +338,7 @@ struct bcma_bus {
u8 num;
struct bcma_drv_cc drv_cc;
--- a/drivers/bcma/host_pci.c
+++ b/drivers/bcma/host_pci.c
-@@ -281,6 +281,8 @@ static const struct pci_device_id bcma_p
- { PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x4365) },
+@@ -282,6 +282,8 @@ static const struct pci_device_id bcma_p
{ PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x43a9) },
+ { PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x43aa) },
{ PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x4727) },
+ { PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 43227) },
+ { PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, 0x4360) },