imagebuilder: fix addition of local packages main master
authorKuan-Yi Li <kyli@abysm.org>
Thu, 20 Feb 2025 21:26:15 +0000 (05:26 +0800)
committerRobert Marko <robimarko@gmail.com>
Fri, 21 Feb 2025 09:44:42 +0000 (10:44 +0100)
Since alpinelinux/apk-tools@460d62ee743c, relative paths are no longer
accepted in repositories file.

Add local repository in APK command instead to fix this issue.

Fixes: 83d2d21904e0 ("apk: update to Git HEAD (2025-02-08)")
Fixes: https://github.com/openwrt/openwrt/issues/18032
Signed-off-by: Kuan-Yi Li <kyli@abysm.org>
Link: https://github.com/openwrt/openwrt/pull/18048
Signed-off-by: Robert Marko <robimarko@gmail.com>
target/imagebuilder/Makefile
target/imagebuilder/files/Makefile

index afc97550c1d4fc0607b55a7bdbc4c394d3df68f1..6fca91939fb2d589dc18fc150aac3915fbd7fedf 100644 (file)
@@ -49,7 +49,6 @@ ifneq ($(CONFIG_USE_APK),)
        $(call FeedSourcesAppendAPK,$(PKG_BUILD_DIR)/repositories)
        $(VERSION_SED_SCRIPT) $(PKG_BUILD_DIR)/repositories
   endif
-       echo "packages/packages.adb" >> $(PKG_BUILD_DIR)/repositories
 
        $(INSTALL_DATA) ./files/README.apk.md $(PKG_BUILD_DIR)/packages/README.md
 else
index b27021d60025eb4de7aa1294c610620688aaad4e..d8c1c3c5e8c3b5c3f2227980be2600facf930610 100644 (file)
@@ -99,6 +99,7 @@ OPKG:=$(call opkg,$(TARGET_DIR)) \
 export APK_KEYS:=$(TOPDIR)/keys
 APK:=$(call apk,$(TARGET_DIR)) \
        --repositories-file $(TOPDIR)/repositories \
+       --repository $(PACKAGE_DIR)/packages.adb \
        $(if $(CONFIG_SIGNATURE_CHECK),,--allow-untrusted) \
        --cache-dir $(DL_DIR)