tools: e2fsprogs: bypass libuuid check
authorRosen Penev <rosenp@gmail.com>
Wed, 25 Sep 2024 17:42:15 +0000 (10:42 -0700)
committerRobert Marko <robimarko@gmail.com>
Thu, 26 Sep 2024 09:08:23 +0000 (11:08 +0200)
The check is the wrong way around. It uses AC_CHECK_LIBS and then
pkg-config, probably because the latter is a second class citizen.

Just bypass it. pkg-config gets used anyway.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/16480
Link: https://github.com/openwrt/openwrt/pull/16480
Link: https://github.com/openwrt/openwrt/pull/16480
Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/e2fsprogs/Makefile

index 8a8a2e181f3f7bcbde29b009a70ce2d314caea22..50c3888b642b4b9521e66db89bf91b3f744fd95a 100644 (file)
@@ -33,6 +33,10 @@ HOST_CONFIGURE_ARGS += \
        --disable-fuse2fs \
        --with-crond-dir=no
 
+# The following uses pkg-config the wrong way around. Just override it.
+HOST_CONFIGURE_VARS += \
+       ac_cv_lib_uuid_uuid_generate=yes
+
 define Host/Prepare
        $(call Host/Prepare/Default)
        rm -rf $(HOST_BUILD_DIR)/doc