apk: update to git e3464d096708b270138653ef93db59134bb24813 (2024-11-13)
authorRobert Marko <robimarko@gmail.com>
Tue, 19 Nov 2024 12:48:06 +0000 (13:48 +0100)
committerRobert Marko <robimarko@gmail.com>
Tue, 19 Nov 2024 18:52:03 +0000 (19:52 +0100)
Allows us to drop the description backport.

Changes:
e3464d0 db: make repository description an atom instead of allocation
417a93c pkg: truncate apkv3 description to 256 bytes
d26b65d db, audit: remove support for files without embedded checksum
64ff8c7 db: allow files starting with a dot in the root directory of apk3 packages
89e4bf1 db, fs: do not extract devices in --usermode
4050f9e db: fix hardlink handling: root directory and v3 checksums
ade0be3 db, extract: handle file/directory extraction errors more consistently
a4837ae package: don't call make_device_tree when APK_NO_CHROOT is set
1e04115 package: respect libexecdir instead of hard-coding /usr/libexec
76970a9 package: move the location of executable package scripts
19b1df7 blob: refactor apk_blob_for_each_segment into apk_blob_foreach_word
e38d5b5 test: add missing alpine tests makefile
fcd4def test: move vertest to cmocka based unit testing infrastructure
8a13ed9 test: fix solver.sh for parallel use
5add6fc (tag: v3.0.0_pre4) apk-tools-3.0.0_pre4
5dd91e3 db: consider --force-no-chroot when determining /dev/fd availability
d86afde db: print message when a file is written to .apk-new
a5aeb3d test: unify makefile and meson tests
a236fdd pkg: use memfd_create only if target root has dev/fd working
563d364 tests: minor updates to root tests
08b4d21 tests: move solver test data to separate directory
c259642 tests: rework solver tests to not require apk-test binary
d2aaf13 commit: sort matched dependencies on error analysis
98d7196 db: fix permissions of arch file
b231eac db: simplify add_repos_from_file
2a3dbfc db: add and use apk_db_parse_file helper to parse files line by line
c1a3e69 db: validate package arch against compatible arches

Link: https://github.com/openwrt/openwrt/pull/17015
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/system/apk/Makefile
package/system/apk/patches/0020-pkg-truncate-apkv3-description-to-256-bytes.patch [deleted file]

index fbb9ef85ee301ebc02ac35bee6e457fe4c76cf32..693c008df95e450cb934ab3bb020867e92cbd622 100644 (file)
@@ -1,13 +1,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=apk
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE_URL=https://gitlab.alpinelinux.org/alpine/apk-tools.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2024-11-08
-PKG_SOURCE_VERSION:=d9c24813d983df9524fa7a2b78fc3132c159a20f
-PKG_MIRROR_HASH:=3d1a79c08ef8c8b9404f9287d9acda6468b8b1c2a99dd384287f522ed3b1a047
+PKG_SOURCE_DATE:=2024-11-13
+PKG_SOURCE_VERSION:=e3464d096708b270138653ef93db59134bb24813
+PKG_MIRROR_HASH:=cc633e5c294c9d92391fba5537dfe2f12f82011b55d282beb0d5d7ceba212962
 
 PKG_VERSION=3.0.0_pre$(subst -,,$(PKG_SOURCE_DATE))
 
diff --git a/package/system/apk/patches/0020-pkg-truncate-apkv3-description-to-256-bytes.patch b/package/system/apk/patches/0020-pkg-truncate-apkv3-description-to-256-bytes.patch
deleted file mode 100644 (file)
index 62cdd9d..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-From 417a93ceae540444fdbd3f76d1dadf0e15621fdc Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
-Date: Wed, 13 Nov 2024 09:40:21 +0200
-Subject: [PATCH] pkg: truncate apkv3 description to 256 bytes
-
-The code to read/write installeddb does not really handle long
-description well. Until the database is converted to apkv3 format,
-truncate the apkv3 descriptions to allow existing code to work.
-
-APKv3 index and packages still contain the original long description
-unmodified, so no package rebuild will be needed.
-
-fixes #11038
-
-Upstream-Status: Backport [https://gitlab.alpinelinux.org/alpine/apk-tools/-/commit/417a93ceae540444fdbd3f76d1dadf0e15621fdc]
----
- src/apk_blob.h | 5 +++++
- src/package.c  | 2 +-
- 2 files changed, 6 insertions(+), 1 deletion(-)
-
---- a/src/apk_blob.h
-+++ b/src/apk_blob.h
-@@ -48,6 +48,11 @@ static inline apk_blob_t apk_blob_trim(a
-       return b;
- }
-+static inline apk_blob_t apk_blob_truncate(apk_blob_t blob, int maxlen)
-+{
-+      return APK_BLOB_PTR_LEN(blob.ptr, min(blob.len, maxlen));
-+}
-+
- char *apk_blob_cstr(apk_blob_t str);
- apk_blob_t apk_blob_dup(apk_blob_t blob);
- int apk_blob_split(apk_blob_t blob, apk_blob_t split, apk_blob_t *l, apk_blob_t *r);
---- a/src/package.c
-+++ b/src/package.c
-@@ -577,7 +577,7 @@ void apk_pkgtmpl_from_adb(struct apk_dat
-       pkg->name = apk_db_get_name(db, adb_ro_blob(pkginfo, ADBI_PI_NAME));
-       pkg->version = apk_atomize_dup(&db->atoms, adb_ro_blob(pkginfo, ADBI_PI_VERSION));
--      pkg->description = apk_atomize_dup0(&db->atoms, adb_ro_blob(pkginfo, ADBI_PI_DESCRIPTION));
-+      pkg->description = apk_atomize_dup0(&db->atoms, apk_blob_truncate(adb_ro_blob(pkginfo, ADBI_PI_DESCRIPTION), 512));
-       pkg->url = apk_atomize_dup(&db->atoms, adb_ro_blob(pkginfo, ADBI_PI_URL));
-       pkg->license = apk_atomize_dup(&db->atoms, adb_ro_blob(pkginfo, ADBI_PI_LICENSE));
-       pkg->arch = apk_atomize_dup(&db->atoms, adb_ro_blob(pkginfo, ADBI_PI_ARCH));