projects
/
openwrt
/
staging
/
robimarko.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
493f7f5
)
toolchain/gdb: export ZSTD_CFLAGS/LIBS to fix build on non-linux systems
author
Felix Fietkau
<nbd@nbd.name>
Sun, 12 Nov 2023 21:20:41 +0000
(22:20 +0100)
committer
Felix Fietkau
<nbd@nbd.name>
Mon, 18 Dec 2023 10:42:08 +0000
(11:42 +0100)
Avoids picking up libs and header files from musl
Signed-off-by: Felix Fietkau <nbd@nbd.name>
toolchain/gdb/Makefile
patch
|
blob
|
history
diff --git
a/toolchain/gdb/Makefile
b/toolchain/gdb/Makefile
index 9c0ed520bdc6d792e0af86d00da3bfddee97ce02..5ad0cd2d8cbf9c43bd1b0f7cf47e36956bc3f607 100644
(file)
--- a/
toolchain/gdb/Makefile
+++ b/
toolchain/gdb/Makefile
@@
-22,6
+22,9
@@
HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/toolchain-build.mk
+export ZSTD_CFLAGS=-I$(STAGING_DIR_HOST)/include
+export ZSTD_LIBS=-L$(STAGING_DIR_HOST)/lib -lzstd
+
HOST_CONFIGURE_VARS += \
acx_cv_cc_gcc_supports_ada=false \
gdb_cv_func_sigsetjmp=yes