projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1590b0f
)
build: use if-then to avoid non-zero return codes in bin/ packaging code
author
Felix Fietkau
<nbd@nbd.name>
Mon, 23 Jan 2017 12:40:15 +0000
(13:40 +0100)
committer
Felix Fietkau
<nbd@nbd.name>
Mon, 23 Jan 2017 12:49:45 +0000
(13:49 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/package-bin.mk
patch
|
blob
|
history
diff --git
a/include/package-bin.mk
b/include/package-bin.mk
index 68f5831340949105280c3dc66718e143ab3dd556..4ae049af5409687f6166d494f50f1da7cb66587e 100644
(file)
--- a/
include/package-bin.mk
+++ b/
include/package-bin.mk
@@
-29,10
+29,10
@@
ifeq ($(DUMP),)
install-bin-$(1): $(PKG_BUILD_DIR)/.pkgdir/$(1).installed
rm -rf $(BIN_DIR)/$(1)
-rmdir $(PKG_BUILD_DIR)/.pkgdir/$(1) >/dev/null 2>/dev/null
-
[ -d $(PKG_BUILD_DIR)/.pkgdir/$(1) ] && {
\
+
if [ -d $(PKG_BUILD_DIR)/.pkgdir/$(1) ]; then
\
$(INSTALL_DIR) $(BIN_DIR)/$(1) && \
$(CP) $(PKG_BUILD_DIR)/.pkgdir/$(1)/. $(BIN_DIR)/$(1)/; \
- }
+ fi
clean-$(1):
rm -rf $(BIN_DIR)/$(1)