rockchip: make SATA(AHCI) really work on Radxa E25
authorFUKAUMI Naoki <naoki@radxa.com>
Wed, 10 Jul 2024 21:20:21 +0000 (06:20 +0900)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 21 Jul 2024 16:22:24 +0000 (18:22 +0200)
kmod-ahci-dwc is required to use SATA(AHCI) on Radxa E25.

Fixes: f7c732bf9e ("rockchip: add Radxa E25 board support")
Signed-off-by: FUKAUMI Naoki <naoki@radxa.com>
Link: https://github.com/openwrt/openwrt/pull/15923
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/rockchip/image/armv8.mk

index 3f1e6934d10753f6d4e9244f99a3836dc9c89312..2405c07d9c190309f8e5ce0c681ae9e1859eb809 100644 (file)
@@ -111,7 +111,7 @@ define Device/radxa_e25
   DEVICE_DTS := rockchip/rk3568-radxa-e25
   BOOT_SCRIPT := radxa-e25
   UBOOT_DEVICE_NAME := radxa-e25-rk3568
-  DEVICE_PACKAGES := kmod-r8169 kmod-ata-ahci-platform
+  DEVICE_PACKAGES := kmod-r8169 kmod-ata-ahci-dwc
 endef
 TARGET_DEVICES += radxa_e25