ath79: linksys_ea4500-v3: take over the space for user data
authorEdward Chow <equu@openmail.cc>
Mon, 4 Mar 2024 17:24:10 +0000 (01:24 +0800)
committerRobert Marko <robimarko@gmail.com>
Thu, 7 Nov 2024 13:56:39 +0000 (14:56 +0100)
The last "syscfg" partition of the OEM firmware turns out to be a
UBIFS used to store user data, just as the "rootfs_data" of OpenWrt,
so it should be reasonable to absorb it into the "ubi" partition.

Factory installations via either OEM firmware or tftp, or by forcibly
flashing factory image to mtd5 (firmware) partition with mtd tool are
confirmed working, but the UBI remaining inside "syscfg" partition
could break upgrade. Fortunately, installing kmod-mtd-rw and erasing
"syscfg" partition before upgrade is confirmed working, in which case,
"ubi" will automatically expand to the blank space once occupied by
the former mtd8 (syscfg), with the total block number increased, but
the UBIFS for rootfs_data will not automatically claim the newly
available space (since it is created when mtd8 still exists, and
sysupgrade does not set "autoresize" flag to rootfs_data). These space
will be claimed during the next upgrade, when rootfs_data is removed
and created again.

Fixes: 50f727b7737d1 ("ath79: add support for Linksys EA4500 v3")
Signed-off-by: Edward Chow <equu@openmail.cc>
Link: https://github.com/openwrt/openwrt/pull/14791
Signed-off-by: Robert Marko <robimarko@gmail.com>
target/linux/ath79/dts/qca9558_linksys_ea4500-v3.dts
target/linux/ath79/image/nand.mk
target/linux/ath79/nand/base-files/etc/board.d/05_compat-version

index 6c799efe33a54eacb3940c20a853147ae06b6e74..1da46d72145b10cc657e77b0f5a411b6e1f1c417 100644 (file)
 
                partition@2c0000 {
                        label = "firmware";
-                       reg = <0x2c0000 0x5000000>;
+                       reg = <0x2c0000 0x7d40000>;
 
                        compatible = "fixed-partitions";
                        #address-cells = <1>;
 
                        partition@400000 {
                                label = "ubi";
-                               reg = <0x400000 0x4c00000>;
+                               reg = <0x400000 0x7940000>;
                        };
 
                        /* Original layout for secondary partitions */
                        }; */
                };
 
-               partition@52c0000 {
+               /* Original layout for user data partition */
+               /* partition@52c0000 {
                        label = "syscfg";
                        reg = <0x52c0000 0x2d40000>;
-                       read-only;
-               };
+               }; */
        };
 };
 
index a3bdedaf6d53d5bcb21c913595f45d56b8843dca..d3c1120aa23ca01e173d7d5b676cbcd819b1d253 100644 (file)
@@ -281,6 +281,12 @@ TARGET_DEVICES += glinet_gl-x1200-nor
 
 define Device/linksys_ea4500-v3
   SOC := qca9558
+  DEVICE_COMPAT_VERSION := 1.1
+  DEVICE_COMPAT_MESSAGE := Partition table has been changed. Please \
+       install kmod-mtd-rw and erase mtd8 (syscfg) before upgrade \
+       to keep configures, or forcibly flash factory image to mtd5 \
+       (firmware) partition with mtd tool to discard configures but \
+       claim additional space immediately.
   DEVICE_VENDOR := Linksys
   DEVICE_MODEL := EA4500
   DEVICE_VARIANT := v3
@@ -288,7 +294,7 @@ define Device/linksys_ea4500-v3
   BLOCKSIZE := 128k
   PAGESIZE := 2048
   KERNEL_SIZE := 4096k
-  IMAGE_SIZE := 81920k
+  IMAGE_SIZE := 128256k
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
   LINKSYS_HWNAME := EA4500V3
   IMAGES += factory.img
index 238927aa7b474c0b119ad3171d36b2b271f8ed3a..4d826d978d62ad23bc7aa29d5db9ef8fbaebb6fa 100644 (file)
@@ -4,6 +4,7 @@
 board_config_update
 
 case "$(board_name)" in
+       linksys,ea4500-v3|\
        netgear,wndr4300-v2|\
        netgear,wndr4500-v3)
                ucidef_set_compat_version "1.1"