projects
/
openwrt
/
staging
/
thess.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
69b1451
)
x86: 6.6: enable System Management Mode emulation on KVM
author
Mieczyslaw Nalewaj
<namiltd@yahoo.com>
Tue, 26 Mar 2024 17:39:01 +0000
(18:39 +0100)
committer
Robert Marko
<robimarko@gmail.com>
Thu, 4 Apr 2024 06:56:10 +0000
(08:56 +0200)
Include the CONFIG_KVM_SMM option in the kvm-x86 package to enable system management mode emulation on KVM.
Co-authored-by: Stefan Hellermann <stefan@the2masters.de>
Signed-off-by: Mieczyslaw Nalewaj <namiltd@yahoo.com>
package/kernel/linux/modules/virt.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/virt.mk
b/package/kernel/linux/modules/virt.mk
index a408ac9b1498b9659529cbbb59c0637ec2090660..4a879f240ebadb81049a221e81be5f7dd9c0bb68 100644
(file)
--- a/
package/kernel/linux/modules/virt.mk
+++ b/
package/kernel/linux/modules/virt.mk
@@
-22,6
+22,7
@@
define KernelPackage/kvm-x86
KCONFIG:=\
CONFIG_KVM \
CONFIG_KVM_MMU_AUDIT=n \
+ CONFIG_KVM_SMM=y@ge6.6 \
CONFIG_VIRTUALIZATION=y
FILES:= $(LINUX_DIR)/arch/$(LINUX_KARCH)/kvm/kvm.ko
AUTOLOAD:=$(call AutoProbe,kvm.ko)