compat-drivers: Enable nouveau DRM driver for kernels >= 3.3
authorOzan Çağlayan <ozancag@gmail.com>
Sun, 28 Oct 2012 17:04:20 +0000 (19:04 +0200)
committerLuis R. Rodriguez <mcgrof@do-not-panic.com>
Sun, 4 Nov 2012 17:20:33 +0000 (09:20 -0800)
Enable Nouveau DRM driver for kernels >= 3.3.

Signed-off-by: Ozan Çağlayan <ozancag@gmail.com>
Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com>
config.mk

index f743e0552477126867ac4488504a631cdcb0a8f2..5941135b9d7d687a6b158aab314cc2f749785f01 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -709,3 +709,12 @@ export CONFIG_COMPAT_DRM_I915=m
 export CONFIG_COMPAT_DRM_LOAD_EDID_FIRMWARE=y
 export CONFIG_COMPAT_DRM_KMS_HELPER=m
 endif #CONFIG_COMPAT_KERNEL_3_2
+
+# Enable nouveau on >= 3.3
+ifndef CONFIG_COMPAT_KERNEL_3_3
+export CONFIG_COMPAT_DRM_TTM=m
+export CONFIG_COMPAT_DRM_NOUVEAU=m
+export CONFIG_COMPAT_DRM_NOUVEAU_BACKLIGHT=y
+export CONFIG_COMPAT_NOUVEAU_DEBUG=5
+export CONFIG_COMPAT_NOUVEAU_DEBUG_DEFAULT=3
+endif #CONFIG_COMPAT_KERNEL_3_3