projects
/
openwrt
/
staging
/
chunkeey.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
61c65ac
)
ipq40xx: fix Edgecore ECW5211 boot
author
Stijn Tintel
<stijn@linux-ipv6.be>
Wed, 18 Aug 2021 13:11:11 +0000
(16:11 +0300)
committer
David Bauer
<mail@david-bauer.net>
Tue, 24 Aug 2021 17:41:47 +0000
(19:41 +0200)
The bootloader will look for a configuration section named ap.dk01.1-c2
in the FIT image. If this doesn't exist, the device won't boot.
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
(cherry picked from commit
a43da1be43ae251f0edaa6419612e600fc6ec972
)
target/linux/ipq40xx/image/generic.mk
patch
|
blob
|
history
diff --git
a/target/linux/ipq40xx/image/generic.mk
b/target/linux/ipq40xx/image/generic.mk
index 358a583f84656e5996a5488468d70624a7fc9f80..a435a127fade6dee74f772e9b7726e1325161f72 100644
(file)
--- a/
target/linux/ipq40xx/image/generic.mk
+++ b/
target/linux/ipq40xx/image/generic.mk
@@
-355,6
+355,7
@@
define Device/edgecore_ecw5211
SOC := qcom-ipq4018
BLOCKSIZE := 128k
PAGESIZE := 2048
+ DEVICE_DTS_CONFIG := config@ap.dk01.1-c2
DEVICE_PACKAGES := kmod-tpm-i2c-atmel kmod-usb-acm
endef
TARGET_DEVICES += edgecore_ecw5211