projects
/
openwrt
/
staging
/
dangole.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6a82f40
)
perf: fix build with kernel 4.9
author
Mathias Kresin
<dev@kresin.me>
Fri, 17 Mar 2017 07:29:42 +0000
(08:29 +0100)
committer
Mathias Kresin
<dev@kresin.me>
Fri, 17 Mar 2017 07:58:50 +0000
(08:58 +0100)
The musl workaround isn't required anymore and causes build errors with
kernel 4.9 when applied.
Signed-off-by: Mathias Kresin <dev@kresin.me>
package/devel/perf/Makefile
patch
|
blob
|
history
diff --git
a/package/devel/perf/Makefile
b/package/devel/perf/Makefile
index f2f8d6c95cc2bf2655d8005c2c40fbd3b5077a2e..a9e11b4e3293516e652c181eab6dbd179582ebba 100644
(file)
--- a/
package/devel/perf/Makefile
+++ b/
package/devel/perf/Makefile
@@
-61,9
+61,11
@@
MAKE_FLAGS = \
WERROR=0 \
prefix=/usr
+ifdef CONFIG_LINUX_4_4
ifdef CONFIG_USE_MUSL
MAKE_FLAGS += EXTRA_CFLAGS="-I$(CURDIR)/musl-include -include $(CURDIR)/musl-compat.h -D__UCLIBC__"
endif
+endif
define Build/Compile
+$(MAKE_FLAGS) $(MAKE) $(PKG_JOBS) \