Upgrade to openssl-0.9.7k, thanks to eJunky !
authorFlorian Fainelli <florian@openwrt.org>
Fri, 8 Sep 2006 07:00:15 +0000 (07:00 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 8 Sep 2006 07:00:15 +0000 (07:00 +0000)
SVN-Revision: 4775

openwrt/package/openssl/Makefile
openwrt/package/openssl/patches/140-makefile-dirs.patch
openwrt/package/openssl/patches/150-remove-fips.patch
openwrt/package/openssl/patches/160-disable_doc_tests.patch

index fdf7fabc4401372c7272a8ef0a0b8020b39be9a3..ee6e69ea88ab74575091b68b79754320dffad134 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
-PKG_VERSION:=0.9.7i
+PKG_VERSION:=0.9.7k
 PKG_RELEASE:=3
-PKG_MD5SUM:=f69d82b206ff8bff9d0e721f97380b9e
+PKG_MD5SUM:=be6bba1d67b26eabb48cf1774925416f
 
 PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
index 7d0153811837588e0a03820ae92eca19bdfc83bd..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,12 +0,0 @@
-diff -Nur openssl-0.9.7f/Makefile.org openssl-0.9.7f.new/Makefile.org
---- openssl-0.9.7f/Makefile.org        2005-03-15 10:46:13.000000000 +0100
-+++ openssl-0.9.7f.new/Makefile.org    2005-04-03 20:15:26.000000000 +0200
-@@ -175,7 +175,7 @@
- # we might set SHLIB_MARK to '$(SHARED_LIBS)'.
- SHLIB_MARK=
--DIRS=   crypto fips ssl $(SHLIB_MARK) sigs apps test tools
-+DIRS=   crypto ssl apps
- SHLIBDIRS= crypto ssl
- # dirs in crypto to build
index e4e3cb48703999452346a27baf498eb2793d44c7..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,21 +0,0 @@
-diff -ruN openssl-0.9.7h-old/Makefile.org openssl-0.9.7h-new/Makefile.org
---- openssl-0.9.7h-old/Makefile.org    2005-10-12 23:12:38.000000000 +0200
-+++ openssl-0.9.7h-new/Makefile.org    2005-10-12 23:13:38.000000000 +0200
-@@ -230,7 +230,6 @@
- libcrypto.a.sha1: libcrypto.a
-       @if egrep 'define OPENSSL_FIPS' $(TOP)/include/openssl/opensslconf.h > /dev/null; then \
-               $(RANLIB) libcrypto.a; \
--              fips/sha/fips_standalone_sha1 libcrypto.a > libcrypto.a.sha1; \
-       fi
- sub_all:
-@@ -258,9 +257,6 @@
- libcrypto$(SHLIB_EXT): libcrypto.a
-       @if [ "$(SHLIB_TARGET)" != "" ]; then \
-               $(MAKE) SHLIBDIRS=crypto build-shared; \
--              if egrep 'define OPENSSL_FIPS' $(TOP)/include/openssl/opensslconf.h > /dev/null; then \
--                    fips/sha/fips_standalone_sha1 -binary $@ > $@.$${HMAC_EXT:-sha1}; \
--              fi; \
-       else \
-               echo "There's no support for shared libraries on this platform" >&2; \
-       fi
index 7aba9e9a6521ba78b87c8aa93801ffb79e4f61e4..fc9e6efc591ada9b9f7eba670907665d31252285 100644 (file)
@@ -1,25 +1,25 @@
-diff -urN openssl-0.9.7i/Makefile openssl-0.9.7i.new/Makefile
---- openssl-0.9.7i/Makefile    2005-10-15 00:27:49.000000000 +0200
-+++ openssl-0.9.7i.new/Makefile        2006-04-15 12:50:22.000000000 +0200
-@@ -178,7 +178,7 @@
+diff -Nur openssl-0.9.7k.orig/Makefile openssl-0.9.7k/Makefile
+--- openssl-0.9.7k.orig/Makefile       2006-09-05 10:40:05.000000000 +0200
++++ openssl-0.9.7k/Makefile    2006-09-06 18:09:28.000000000 +0200
+@@ -196,7 +196,7 @@
  # we might set SHLIB_MARK to '$(SHARED_LIBS)'.
  SHLIB_MARK=
  
--DIRS=   crypto fips ssl $(SHLIB_MARK) sigs apps test tools
-+DIRS=   crypto fips ssl $(SHLIB_MARK) sigs apps tools
+-DIRS=   crypto fips-1.0 ssl $(SHLIB_MARK) apps test tools
++DIRS=   crypto fips-1.0 ssl $(SHLIB_MARK) apps tools
  SHLIBDIRS= crypto ssl
  
  # dirs in crypto to build
-@@ -193,7 +193,7 @@
+@@ -211,7 +211,7 @@
  
  # tests to perform.  "alltests" is a special word indicating that all tests
  # should be performed.
 -TESTS = alltests
-+TESTS = 
++TESTS =
  
  MAKEFILE= Makefile
  
-@@ -205,7 +205,7 @@
+@@ -223,7 +223,7 @@
  
  TOP=    .
  ONEDIRS=out tmp
@@ -27,8 +27,8 @@ diff -urN openssl-0.9.7i/Makefile openssl-0.9.7i.new/Makefile
 +EDIRS=  times bugs util include certs ms shlib mt demos perl sf dep VMS
  WDIRS=  windows
  LIBS=   libcrypto.a libssl.a
- SIGS= libcrypto.a.sha1
-@@ -773,7 +773,7 @@
+ SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
+@@ -781,7 +781,7 @@
  dist_pem_h:
        (cd crypto/pem; $(MAKE) CC='${CC}' SDIRS='${SDIRS}' CFLAG='${CFLAG}' pem.h; $(MAKE) clean)
  
@@ -37,19 +37,28 @@ diff -urN openssl-0.9.7i/Makefile openssl-0.9.7i.new/Makefile
  
  install_sw:
        @$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
-diff -urN openssl-0.9.7i/Makefile.org openssl-0.9.7i.new/Makefile.org
---- openssl-0.9.7i/Makefile.org        2006-04-15 12:47:55.000000000 +0200
-+++ openssl-0.9.7i.new/Makefile.org    2006-04-15 12:51:18.000000000 +0200
-@@ -191,7 +191,7 @@
+diff -Nur openssl-0.9.7k.orig/Makefile.org openssl-0.9.7k/Makefile.org
+--- openssl-0.9.7k.orig/Makefile.org   2006-04-24 15:32:57.000000000 +0200
++++ openssl-0.9.7k/Makefile.org        2006-09-06 18:10:05.000000000 +0200
+@@ -194,7 +194,7 @@
+ # we might set SHLIB_MARK to '$(SHARED_LIBS)'.
+ SHLIB_MARK=
+-DIRS=   crypto fips-1.0 ssl $(SHLIB_MARK) apps test tools
++DIRS=   crypto ssl apps
+ SHLIBDIRS= crypto ssl
+ # dirs in crypto to build
+@@ -209,7 +209,7 @@
  
  # tests to perform.  "alltests" is a special word indicating that all tests
  # should be performed.
 -TESTS = alltests
-+TESTS = 
++TESTS =
  
  MAKEFILE= Makefile
  
-@@ -203,7 +203,7 @@
+@@ -221,7 +221,7 @@
  
  TOP=    .
  ONEDIRS=out tmp
@@ -57,8 +66,8 @@ diff -urN openssl-0.9.7i/Makefile.org openssl-0.9.7i.new/Makefile.org
 +EDIRS=  times bugs util include certs ms shlib mt demos perl sf dep VMS
  WDIRS=  windows
  LIBS=   libcrypto.a libssl.a
- SIGS= libcrypto.a.sha1
-@@ -767,7 +767,7 @@
+ SHARED_CRYPTO=libcrypto$(SHLIB_EXT)
+@@ -779,7 +779,7 @@
  dist_pem_h:
        (cd crypto/pem; $(MAKE) CC='${CC}' SDIRS='${SDIRS}' CFLAG='${CFLAG}' pem.h; $(MAKE) clean)