projects
/
openwrt
/
staging
/
thess.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
7ab328b
)
add support for KernelPackage/*/description
author
Nicolas Thill
<nico@openwrt.org>
Sat, 25 Aug 2007 14:43:15 +0000
(14:43 +0000)
committer
Nicolas Thill
<nico@openwrt.org>
Sat, 25 Aug 2007 14:43:15 +0000
(14:43 +0000)
SVN-Revision: 8484
include/kernel.mk
patch
|
blob
|
history
diff --git
a/include/kernel.mk
b/include/kernel.mk
index df859a42b033ae5191870d7ecc527e90afeb2066..7f035c7bc5264fa56fa0bd31f78a849fbfe5b7a8 100644
(file)
--- a/
include/kernel.mk
+++ b/
include/kernel.mk
@@
-99,6
+99,12
@@
define KernelPackage
$(call KernelPackage/$(1)/$(BOARD)-$(KERNEL))
endef
+ ifdef KernelPackage/$(1)/description
+ define Package/kmod-$(1)/description
+$(call KernelPackage/$(1)/description)
+ endef
+ endif
+
ifneq ($(if $(KCONFIG),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
ifneq ($(strip $(FILES)),)
define Package/kmod-$(1)/install