gdb: Update to version 15.2
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 10 Oct 2024 20:13:40 +0000 (22:13 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 12 Oct 2024 19:51:24 +0000 (21:51 +0200)
See news file for changes:
https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=blob_plain;f=gdb/NEWS;hb=gdb-15.1-release

Link: https://github.com/openwrt/openwrt/pull/16665
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/devel/gdb/Makefile
package/devel/gdb/patches/001-gdb-pr14523-mips-signal-number.patch
package/devel/gdb/patches/110-shared_libgcc.patch
package/devel/gdb/patches/120-sigprocmask-invalid-call.patch
package/devel/gdb/patches/130-gdb-ctrl-c.patch
package/devel/gdb/patches/140-sgidefs.patch
package/devel/gdb/patches/150-mips64.patch

index cf897b79f2730e94a85ca039b4ba42f1e8d040e6..366746be87fbaf3aafdc80d898dc3b1c28fe1285 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=14.1
+PKG_VERSION:=15.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
-PKG_HASH:=d66df51276143451fcbff464cc8723d68f1e9df45a6a2d5635a54e71643edb80
+PKG_HASH:=83350ccd35b5b5a0cba6b334c41294ea968158c573940904f00b92f76345314d
 
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
index b8e7b10fc9817bcc40967b31600ceb9bcbb0c607..dd6cdbdbc896b97412153a1326cf8145a2e2c889 100644 (file)
@@ -2,7 +2,7 @@ See http://sourceware.org/bugzilla/show_bug.cgi?id=14523
 
 --- a/gdbsupport/signals.cc
 +++ b/gdbsupport/signals.cc
-@@ -348,6 +348,11 @@ gdb_signal_from_host (int hostsig)
+@@ -347,6 +347,11 @@ gdb_signal_from_host (int hostsig)
        else if (64 <= hostsig && hostsig <= 127)
        return (enum gdb_signal)
          (hostsig - 64 + (int) GDB_SIGNAL_REALTIME_64);
index 1a02ad11603cf8e7e69a046707c4afd05c3cabd5..d9dcafe0e0092b978cb1312f8833ccc8388d559f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1400,13 +1400,13 @@ if test -z "$LD"; then
+@@ -1401,13 +1401,13 @@ if test -z "$LD"; then
    fi
  fi
  
@@ -17,7 +17,7 @@
    AC_LANG_PUSH(C++)
    AC_LINK_IFELSE([AC_LANG_SOURCE([
  #if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
-@@ -1836,7 +1836,7 @@ AC_ARG_WITH(stage1-ldflags,
+@@ -1837,7 +1837,7 @@ AC_ARG_WITH(stage1-ldflags,
   # trust that they are doing what they want.
   if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
       -a "$have_static_libs" = yes; then
   fi])
  AC_SUBST(stage1_ldflags)
  
-@@ -1865,7 +1865,7 @@ AC_ARG_WITH(boot-ldflags,
+@@ -1866,7 +1866,7 @@ AC_ARG_WITH(boot-ldflags,
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then
 -   poststage1_ldflags="-static-libstdc++ -static-libgcc"
 +   poststage1_ldflags="-static-libstdc++"
   fi])
- AC_SUBST(poststage1_ldflags)
+ case $target in
+   *-darwin2* | *-darwin1[[56789]]*)
 --- a/configure
 +++ b/configure
-@@ -5413,14 +5413,14 @@ if test -z "$LD"; then
+@@ -5414,14 +5414,14 @@ if test -z "$LD"; then
    fi
  fi
  
@@ -56,7 +56,7 @@
    ac_ext=cpp
  ac_cpp='$CXXCPP $CPPFLAGS'
  ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-@@ -8464,7 +8464,7 @@ else
+@@ -8465,7 +8465,7 @@ else
   # trust that they are doing what they want.
   if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
       -a "$have_static_libs" = yes; then
@@ -65,7 +65,7 @@
   fi
  fi
  
-@@ -8500,7 +8500,7 @@ else
+@@ -8501,7 +8501,7 @@ else
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then
index 1ac8f5f2ce33cc9c837518325dfbcefb0b76ed71..0796c34c76bc0daacc41ecfca03569f028028895 100644 (file)
@@ -27,7 +27,7 @@ gdb/ChangeLog:
 
 --- a/gdbsupport/signals-state-save-restore.cc
 +++ b/gdbsupport/signals-state-save-restore.cc
-@@ -38,7 +38,7 @@ save_original_signals_state (bool quiet)
+@@ -37,7 +37,7 @@ save_original_signals_state (bool quiet)
    int i;
    int res;
  
index 5272b7e96989d74747597a7190fa89f305a16be6..8cb7a021f3dae16f71482d93386305dbd803b06f 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
 
 --- a/gdbserver/linux-low.cc
 +++ b/gdbserver/linux-low.cc
-@@ -5481,7 +5481,7 @@ linux_process_target::request_interrupt
+@@ -5525,7 +5525,7 @@ linux_process_target::request_interrupt
  {
    /* Send a SIGINT to the process group.  This acts just like the user
       typed a ^C on the controlling terminal.  */
index 05b30f5242515bd3aea00d102fa1216508818e95..1753e9bb850f6db8997eb81915fdf9938b25680e 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
 
 --- a/gdb/mips-linux-nat.c
 +++ b/gdb/mips-linux-nat.c
-@@ -31,7 +31,7 @@
+@@ -30,7 +30,7 @@
  #include "gdb_proc_service.h"
  #include "gregset.h"
  
index 65418fd290f116c81c0cdd36410a4ac1c4ae341a..41c267bcf60d03da014c94cdafb4c629b02b22c2 100644 (file)
@@ -18,7 +18,7 @@ Upstream-Status: Pending
 
 --- a/gdb/mips-linux-nat.c
 +++ b/gdb/mips-linux-nat.c
-@@ -42,6 +42,11 @@
+@@ -41,6 +41,11 @@
  #define PTRACE_GET_THREAD_AREA 25
  #endif