./scripts/admin-update.sh refresh
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Wed, 28 Apr 2010 21:48:28 +0000 (14:48 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Wed, 28 Apr 2010 21:48:28 +0000 (14:48 -0700)
Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
patches/01-netdev.patch
patches/03-rfkill.patch
patches/04-netns.patch
patches/05-usb.patch
patches/08-rename-iwl4965-config.patch
patches/16-bluetooth.patch
patches/18-rename-usb-net-symbols.patch
patches/20-pcidev.patch
patches/22-multiqueue.patch
patches/25-multicast-list_head.patch
patches/26-sdio-quirks.patch

index 924376b0fd2de249395af52b45cbee2b3defb2a1..01dbbceca26eebe7f4c8976a862f803ea0a89d4a 100644 (file)
@@ -550,7 +550,7 @@ without creating a headache on maintenance of the pathes.
  #define LBS_DEB_LEAVE 0x00000002
 --- a/drivers/net/wireless/mac80211_hwsim.c
 +++ b/drivers/net/wireless/mac80211_hwsim.c
-@@ -1049,16 +1049,22 @@ static struct device_driver mac80211_hws
+@@ -1078,16 +1078,22 @@ static struct device_driver mac80211_hws
        .name = "mac80211_hwsim"
  };
  
index e17ab0925fccbe8a191a0ced11eabbc1cdb5fb57..ef2d8ec2d463ddd2f933ee5d9454af80f8fe4fb2 100644 (file)
@@ -208,7 +208,7 @@ This would do the policing from within mac80211.
  #include <net/cfg80211.h>
 --- a/drivers/net/wireless/ath/ath9k/hw.c
 +++ b/drivers/net/wireless/ath/ath9k/hw.c
-@@ -3183,7 +3183,7 @@ int ath9k_hw_fill_cap_info(struct ath_hw
+@@ -2134,7 +2134,7 @@ int ath9k_hw_fill_cap_info(struct ath_hw
  
        pCap->hw_caps |= ATH9K_HW_CAP_ENHANCEDPM;
  
index 5325a190c64e365192e3c42317323d06cb243386..18f8c85b8b517b991403fd63bfab852e09a8fcec 100644 (file)
@@ -16,7 +16,7 @@ files...
  };
  
  /* internal helper: get rdev and dev */
-@@ -4203,7 +4205,9 @@ static int nl80211_wiphy_netns(struct sk
+@@ -4207,7 +4209,9 @@ static int nl80211_wiphy_netns(struct sk
  
        err = cfg80211_switch_netns(rdev, net);
   out_put_net:
@@ -65,7 +65,7 @@ files...
  
                if (sysfs_create_link(&dev->dev.kobj, &rdev->wiphy.dev.kobj,
                                      "phy80211")) {
-@@ -828,6 +834,7 @@ static struct notifier_block cfg80211_ne
+@@ -829,6 +835,7 @@ static struct notifier_block cfg80211_ne
        .notifier_call = cfg80211_netdev_notifier_call,
  };
  
@@ -73,7 +73,7 @@ files...
  static void __net_exit cfg80211_pernet_exit(struct net *net)
  {
        struct cfg80211_registered_device *rdev;
-@@ -845,14 +852,17 @@ static void __net_exit cfg80211_pernet_e
+@@ -846,14 +853,17 @@ static void __net_exit cfg80211_pernet_e
  static struct pernet_operations cfg80211_pernet_ops = {
        .exit = cfg80211_pernet_exit,
  };
@@ -91,7 +91,7 @@ files...
  
        err = wiphy_sysfs_init();
        if (err)
-@@ -887,8 +897,10 @@ out_fail_nl80211:
+@@ -888,8 +898,10 @@ out_fail_nl80211:
  out_fail_notifier:
        wiphy_sysfs_exit();
  out_fail_sysfs:
@@ -102,7 +102,7 @@ files...
        return err;
  }
  subsys_initcall(cfg80211_init);
-@@ -900,7 +912,9 @@ static void cfg80211_exit(void)
+@@ -901,7 +913,9 @@ static void cfg80211_exit(void)
        unregister_netdevice_notifier(&cfg80211_netdev_notifier);
        wiphy_sysfs_exit();
        regulatory_exit();
index 823097e51eee7b8d1cdfabe26c03a4d99cee9817..7420d697021416fb6465785c778a8cf78636e66b 100644 (file)
@@ -14,7 +14,7 @@ USB opt soft_unbid was added as of 2.6.27.
  static int __init p54u_init(void)
 --- a/drivers/net/wireless/ath/ath9k/hif_usb.c
 +++ b/drivers/net/wireless/ath/ath9k/hif_usb.c
-@@ -970,7 +970,9 @@ static struct usb_driver ath9k_hif_usb_d
+@@ -994,7 +994,9 @@ static struct usb_driver ath9k_hif_usb_d
        .reset_resume = ath9k_hif_usb_resume,
  #endif
        .id_table = ath9k_hif_usb_ids,
index 6c73a539b60a1b071ad4f7260d2df211a607c154..624aed481a616d4fcdb6c7717af8bdc3c06d83b2 100644 (file)
@@ -5,9 +5,9 @@ CONFIG_IWL4965 has to be set to y, to build correctly.
 
 --- a/drivers/net/wireless/iwlwifi/Makefile
 +++ b/drivers/net/wireless/iwlwifi/Makefile
-@@ -13,7 +13,7 @@ iwlagn-objs          := iwl-agn.o iwl-agn-rs.o i
- iwlagn-objs           += iwl-agn-ucode.o iwl-agn-hcmd.o iwl-agn-tx.o
+@@ -14,7 +14,7 @@ iwlagn-objs          += iwl-agn-ucode.o iwl-agn-
  iwlagn-objs           += iwl-agn-lib.o
+ iwlagn-$(CONFIG_IWLWIFI_DEBUGFS) += iwl-agn-debugfs.o
  
 -iwlagn-$(CONFIG_IWL4965) += iwl-4965.o
 +iwlagn-$(CONFIG_COMPAT_IWL4965) += iwl-4965.o
@@ -16,7 +16,7 @@ CONFIG_IWL4965 has to be set to y, to build correctly.
  iwlagn-$(CONFIG_IWL5000) += iwl-1000.o
 --- a/drivers/net/wireless/iwlwifi/iwl-agn.c
 +++ b/drivers/net/wireless/iwlwifi/iwl-agn.c
-@@ -3761,10 +3761,10 @@ static void __devexit iwl_pci_remove(str
+@@ -3723,10 +3723,10 @@ static void __devexit iwl_pci_remove(str
  
  /* Hardware specific file defines the PCI IDs table for that hardware module */
  static DEFINE_PCI_DEVICE_TABLE(iwl_hw_card_ids) = {
index 0fb973262bffaa3d33a32699b563bbe91071eb32..eac00dfae36d9d134acae31d60298d72f2b988bc 100644 (file)
@@ -595,7 +595,7 @@ here still, but for now we keep this here.
                return -EPERM;
  
        sock->ops = &l2cap_sock_ops;
-@@ -1767,7 +1775,11 @@ static int l2cap_sock_setsockopt_old(str
+@@ -1770,7 +1778,11 @@ static int l2cap_sock_setsockopt_old(str
        return err;
  }
  
index 73698178ba2740a2594aa39c368fbba7824f6fc7..548a7a4967729e967ea15ac9ad34753bf1c21ea1 100644 (file)
@@ -28,7 +28,7 @@ Remove this patch if these symbols are backported.
 +obj-$(CONFIG_USB_COMPAT_USBNET)       += usbnet.o
  obj-$(CONFIG_USB_NET_INT51X1) += int51x1.o
  obj-$(CONFIG_USB_CDC_PHONET)  += cdc-phonet.o
+ obj-$(CONFIG_USB_IPHETH)      += ipheth.o
 --- a/drivers/net/usb/cdc_ether.c
 +++ b/drivers/net/usb/cdc_ether.c
 @@ -33,7 +33,7 @@
index cb7f1cabc8941e9c8ea1f8046c303ade5abfeb6e..e892dcccd2f90dfee5710aa7a8faae3e17798812 100644 (file)
@@ -4,7 +4,7 @@ compat_is_pcie() when needed.
 
 --- a/drivers/net/wireless/ath/ath9k/pci.c
 +++ b/drivers/net/wireless/ath/ath9k/pci.c
-@@ -79,7 +79,11 @@ static void ath_pci_bt_coex_prep(struct 
+@@ -80,7 +80,11 @@ static void ath_pci_bt_coex_prep(struct 
        struct pci_dev *pdev = to_pci_dev(sc->dev);
        u8 aspm;
  
index f6bd3e043b8bb51919fecd5eaf68c8c7f107c916..39f481aa249d63528daca1a6d4ab10da31c6611f 100644 (file)
@@ -96,7 +96,7 @@ queue by using skb_set_queue_mapping(skb, 0) through ieee80211_tx_skb()
  
 --- a/net/mac80211/tx.c
 +++ b/net/mac80211/tx.c
-@@ -1563,6 +1563,10 @@ static void ieee80211_xmit(struct ieee80
+@@ -1571,6 +1571,10 @@ static void ieee80211_xmit(struct ieee80
                                return;
                        }
  
@@ -107,7 +107,7 @@ queue by using skb_set_queue_mapping(skb, 0) through ieee80211_tx_skb()
        ieee80211_set_qos_hdr(local, skb);
        ieee80211_tx(sdata, skb, false);
        rcu_read_unlock();
-@@ -2032,8 +2036,15 @@ void ieee80211_tx_pending(unsigned long 
+@@ -2040,8 +2044,15 @@ void ieee80211_tx_pending(unsigned long 
  
                if (skb_queue_empty(&local->pending[i]))
                        list_for_each_entry_rcu(sdata, &local->interfaces, list)
index bd8f2bdb718b6bd1084fd60fd73f3109b70b2cc0..d18735ca3cece5abe6b5ba4f0ea53035b42e895c 100644 (file)
@@ -174,7 +174,7 @@ This also backport commit 2f787b0b76bf5de2eaa3ca3a29d89123ae03c856
  static void ath5k_configure_filter(struct ieee80211_hw *hw,
                unsigned int changed_flags,
                unsigned int *new_flags,
-@@ -3105,20 +3109,42 @@ unlock:
+@@ -3108,20 +3112,42 @@ unlock:
  }
  
  static u64 ath5k_prepare_multicast(struct ieee80211_hw *hw,
@@ -217,7 +217,7 @@ This also backport commit 2f787b0b76bf5de2eaa3ca3a29d89123ae03c856
                pos ^= (val >> 18) ^ (val >> 12) ^ (val >> 6) ^ val;
                pos &= 0x3f;
                mfilt[pos / 32] |= (1 << (pos % 32));
-@@ -3127,6 +3153,9 @@ static u64 ath5k_prepare_multicast(struc
+@@ -3130,6 +3156,9 @@ static u64 ath5k_prepare_multicast(struc
                * neet to inform below to not reset the mcast */
                /* ath5k_hw_set_mcast_filterindex(ah,
                 *      ha->addr[5]); */
@@ -266,7 +266,7 @@ This also backport commit 2f787b0b76bf5de2eaa3ca3a29d89123ae03c856
        }
 --- a/drivers/net/wireless/libertas_tf/main.c
 +++ b/drivers/net/wireless/libertas_tf/main.c
-@@ -369,20 +369,36 @@ static int lbtf_op_config(struct ieee802
+@@ -418,20 +418,36 @@ static int lbtf_op_config(struct ieee802
  }
  
  static u64 lbtf_op_prepare_multicast(struct ieee80211_hw *hw,
@@ -393,7 +393,7 @@ This also backport commit 2f787b0b76bf5de2eaa3ca3a29d89123ae03c856
        if (cmd != NULL) {
 --- a/drivers/net/wireless/orinoco/hw.c
 +++ b/drivers/net/wireless/orinoco/hw.c
-@@ -1063,7 +1063,11 @@ int __orinoco_hw_set_multicast_list(stru
+@@ -1089,7 +1089,11 @@ int __orinoco_hw_set_multicast_list(stru
                netdev_for_each_mc_addr(ha, dev) {
                        if (i == mc_count)
                                break;
@@ -494,9 +494,9 @@ This also backport commit 2f787b0b76bf5de2eaa3ca3a29d89123ae03c856
 +      int i;
 +#endif
        struct wl1271 *wl = hw->priv;
+       int i;
  
-       if (unlikely(wl->state == WL1271_STATE_OFF))
-@@ -1322,16 +1331,40 @@ static u64 wl1271_op_prepare_multicast(s
+@@ -1323,16 +1332,40 @@ static u64 wl1271_op_prepare_multicast(s
        }
  
        /* update multicast filtering parameters */
@@ -576,7 +576,7 @@ This also backport commit 2f787b0b76bf5de2eaa3ca3a29d89123ae03c856
        return hash.low | ((u64)hash.high << 32);
 --- a/include/net/mac80211.h
 +++ b/include/net/mac80211.h
-@@ -1631,7 +1631,11 @@ struct ieee80211_ops {
+@@ -1642,7 +1642,11 @@ struct ieee80211_ops {
                                 struct ieee80211_bss_conf *info,
                                 u32 changed);
        u64 (*prepare_multicast)(struct ieee80211_hw *hw,
index 0b43be53670b1a7dbd67e894a30d461c8f76f2e6..2fec33d32a83994a71edb8bf9a31b3d444470953 100644 (file)
@@ -2,7 +2,7 @@ The quirks attribute is not available on older kernels.
 
 --- a/drivers/net/wireless/libertas/if_sdio.c
 +++ b/drivers/net/wireless/libertas/if_sdio.c
-@@ -1026,6 +1026,7 @@ static int if_sdio_probe(struct sdio_fun
+@@ -1003,6 +1003,7 @@ static int if_sdio_probe(struct sdio_fun
        if (ret)
                goto disable;
  
@@ -10,7 +10,7 @@ The quirks attribute is not available on older kernels.
        /* For 1-bit transfers to the 8686 model, we need to enable the
         * interrupt flag in the CCCR register. Set the MMC_QUIRK_LENIENT_FN0
         * bit to allow access to non-vendor registers. */
-@@ -1044,6 +1045,7 @@ static int if_sdio_probe(struct sdio_fun
+@@ -1021,6 +1022,7 @@ static int if_sdio_probe(struct sdio_fun
                if (ret)
                        goto release_int;
        }