kernel: update dependency of kmod-i2c-piix4
authorJohn Audia <therealgraysky@proton.me>
Wed, 20 Nov 2024 19:32:09 +0000 (14:32 -0500)
committerZoltan HERPAI <wigyori@uid0.hu>
Tue, 17 Dec 2024 22:28:10 +0000 (23:28 +0100)
Add 6.12 specific dependency

Package kmod-i2c-piix4 is missing dependencies for the following libraries:
i2c-smbus.ko

Signed-off-by: John Audia <therealgraysky@proton.me>
package/kernel/linux/modules/i2c.mk

index 3aaf560ea908dbbfa57c78d3bb1240ef6fcf5828..8b47628da26c6a6f27182517df010c10859c6d3e 100644 (file)
@@ -289,7 +289,7 @@ I2C_PIIX4_MODULES:= \
 define KernelPackage/i2c-piix4
   $(call i2c_defaults,$(I2C_PIIX4_MODULES),59)
   TITLE:=Intel PIIX4 and compatible I2C interfaces
-  DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-core
+  DEPENDS:=@PCI_SUPPORT @TARGET_x86 +kmod-i2c-core +LINUX_6_12:kmod-i2c-smbus
 endef
 
 define KernelPackage/i2c-piix4/description