projects
/
openwrt
/
staging
/
zorun.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a1a5f59
)
openssl: to disable mips16, use the new PKG_USE_MIPS16 flag instead of messing with...
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 14 Aug 2013 13:02:33 +0000
(13:02 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 14 Aug 2013 13:02:33 +0000
(13:02 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 37771
package/libs/openssl/Makefile
patch
|
blob
|
history
diff --git
a/package/libs/openssl/Makefile
b/package/libs/openssl/Makefile
index 8b0f5243bbf3d7acc7bf21e86f0445f305782373..8f4f93d8529517608c26bc300b6c7952c467ecf0 100644
(file)
--- a/
package/libs/openssl/Makefile
+++ b/
package/libs/openssl/Makefile
@@
-10,6
+10,7
@@
include $(TOPDIR)/rules.mk
PKG_NAME:=openssl
PKG_VERSION:=1.0.1e
PKG_RELEASE:=2
+PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.openssl.org/source/ \
@@
-120,7
+121,7
@@
define Build/Configure
)
endef
-TARGET_CFLAGS
:= $(filter-out -mips16 -minterlink-mips16,$(TARGET_CFLAGS))
$(FPIC)
+TARGET_CFLAGS
+=
$(FPIC)
define Build/Compile
# XXX: OpenSSL "make depend" will look for installed headers before its own,