projects
/
openwrt
/
staging
/
ynezz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
668c988
)
tools: fakeroot: use TCP as IPC transport
author
Jo-Philipp Wich
<jo@mein.io>
Tue, 8 Sep 2020 11:52:10 +0000
(13:52 +0200)
committer
Jo-Philipp Wich
<jo@mein.io>
Wed, 9 Sep 2020 11:33:50 +0000
(13:33 +0200)
Some environments, e.g. first gen WSL, do not support SysV IPC.
Enforce the use of TCP transport instead which should be universally
available.
Fixes: FS#3317
Ref: https://github.com/microsoft/WSL/issues/4067
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
tools/fakeroot/Makefile
patch
|
blob
|
history
diff --git
a/tools/fakeroot/Makefile
b/tools/fakeroot/Makefile
index 5bb8ab342c08b07277d1c3a952e2e3b258e3e009..9ab2679626509be90268d827960306b2ed0f40f1 100644
(file)
--- a/
tools/fakeroot/Makefile
+++ b/
tools/fakeroot/Makefile
@@
-19,4
+19,7
@@
HOST_CONFIGURE_VARS += \
ac_cv_header_sys_capability_h=no \
ac_cv_func_capset=no
+HOST_CONFIGURE_ARGS += \
+ --with-ipc=tcp
+
$(eval $(call HostBuild))