bcm53xx: enable CONFIG_EEPROM_AT24
authorLech Perczak <lech.perczak@gmail.com>
Wed, 2 Oct 2024 13:07:47 +0000 (15:07 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 21 Oct 2024 22:39:32 +0000 (00:39 +0200)
Meraki MX6x devices use them to store MAC address, so it is required to be
built-in for networking to probe properly, before preinit network setup
happens, which in turn is required for proper failsafe mode access.
Enable CONFIG_EEPROM_AT24 for the target.

Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/16634
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/bcm53xx/config-6.6
target/linux/bcm53xx/image/Makefile

index 37088eb101459cbf59d31fb7e2cf5dac641e06f3..26fa0235959881fb878f407965a9c2f0c3c36b21 100644 (file)
@@ -125,6 +125,7 @@ CONFIG_DTC=y
 CONFIG_EARLY_PRINTK=y
 CONFIG_EDAC_ATOMIC_SCRUB=y
 CONFIG_EDAC_SUPPORT=y
+CONFIG_EEPROM_AT24=y
 CONFIG_EXCLUSIVE_SYSTEM_RAM=y
 CONFIG_EXTCON=y
 CONFIG_FIXED_PHY=y
index e02eba387c85f9bbe9006a47b11b7c97bd02c5e4..501486c06319f700d98acebf046edde1e77d9133 100644 (file)
@@ -382,7 +382,7 @@ TARGET_DEVICES += luxul_xwr-3150
 define Device/meraki_mr26
   DEVICE_VENDOR := Meraki
   DEVICE_MODEL := MR26
-  DEVICE_PACKAGES := $(B43) kmod-i2c-bcm-iproc kmod-eeprom-at24 \
+  DEVICE_PACKAGES := $(B43) kmod-i2c-bcm-iproc \
        kmod-hwmon-ina2xx kmod-leds-uleds nu801
   DEVICE_DTS := bcm53015-meraki-mr26
 # resize the initramfs to fit the size of the existing part.safe.
@@ -399,7 +399,7 @@ TARGET_DEVICES += meraki_mr26
 define Device/meraki_mr32
   DEVICE_VENDOR := Meraki
   DEVICE_MODEL := MR32
-  DEVICE_PACKAGES := $(B43) kmod-i2c-bcm-iproc kmod-eeprom-at24 \
+  DEVICE_PACKAGES := $(B43) kmod-i2c-bcm-iproc \
        kmod-leds-pwm kmod-hwmon-ina2xx kmod-bluetooth
   DEVICE_DTS := bcm53016-meraki-mr32
 # Meraki FW r23 tries to resize the part.safe partition before it will