restorefactory: update to release 5
authorNuno Goncalves <nunojpg@gmail.com>
Wed, 5 Jan 2011 15:34:05 +0000 (15:34 +0000)
committerNuno Goncalves <nunojpg@gmail.com>
Wed, 5 Jan 2011 15:34:05 +0000 (15:34 +0000)
SVN-Revision: 24910

utils/restorefactory/Makefile
utils/restorefactory/files/uci_defaults_restorefactory

index 5823df2586be74e2a54dee10b6f307069f0798a9..a3fda806e8930fb637b64800ca953eed25941b1c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=restorefactory
 PKG_VERSION:=1
-PKG_RELEASE:=3
+PKG_RELEASE:=5
 
 include $(INCLUDE_DIR)/package.mk
 
index ad27b4808505223630a85df5568ec7b158aba83e..558bbd6bd8c88c44a58c13bee5568009050fbd5a 100755 (executable)
@@ -1,6 +1,10 @@
 #!/bin/sh
-uci add system restorefactory
-uci set system.@restorefactory[0].button=reset
-uci set system.@restorefactory[0].action=pressed
-uci set system.@restorefactory[0].timeout=5
-uci commit
+
+[ -n "$(uci -q show system.@restorefactory[0])" ] || {
+       uci add system restorefactory
+       uci set system.@restorefactory[0].button=reset
+       uci set system.@restorefactory[0].action=pressed
+       uci set system.@restorefactory[0].timeout=5
+       uci commit
+}
+