Don't build PCMCIA modules when PCMCIA isn't present
authorPhilip A Prindeville <philipp@redfish-solutions.com>
Sat, 15 Aug 2009 05:46:25 +0000 (22:46 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 18 Aug 2009 23:30:09 +0000 (16:30 -0700)
If you're building for a platform that has (for example) no PCMCIA/
Cardbus, then having a single knob to turn to disable this is a
major win.  Especially if more devices get add later that are
PCMCIA-based.

Tested.

Signed-off-by: Philip A Prindeville <philipp@redfish-solutions.com>
config.mk

index 0c3ea9815f8e3f8f331ce378fe9bceb4fc84c8b1..a24b7bd1f98d62a3badbcb1e94fd72fd2b453189 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -191,7 +191,9 @@ CONFIG_B43=m
 CONFIG_B43_HWRNG=y
 CONFIG_B43_PCI_AUTOSELECT=y
 CONFIG_B43_PCICORE_AUTOSELECT=y
+ifneq ($(CONFIG_PCMCIA),)
 CONFIG_B43_PCMCIA=y
+endif
 CONFIG_B43_PIO=y
 CONFIG_B43_LEDS=y
 CONFIG_B43_RFKILL=y
@@ -242,8 +244,10 @@ CONFIG_SSB_BLOCKIO=y
 CONFIG_SSB_PCIHOST_POSSIBLE=y
 CONFIG_SSB_PCIHOST=y
 CONFIG_SSB_B43_PCI_BRIDGE=y
+ifneq ($(CONFIG_PCMCIA),)
 CONFIG_SSB_PCMCIAHOST_POSSIBLE=y
 CONFIG_SSB_PCMCIAHOST=y
+endif
 # CONFIG_SSB_DEBUG=y
 CONFIG_SSB_DRIVER_PCICORE_POSSIBLE=y
 CONFIG_SSB_DRIVER_PCICORE=y
@@ -258,7 +262,9 @@ CONFIG_B44_PCI=y
 CONFIG_RTL8180=m
 
 CONFIG_ADM8211=m
+ifneq ($(CONFIG_PCMCIA),)
 CONFIG_PCMCIA_ATMEL=m
+endif
 
 CONFIG_RT2X00_LIB_PCI=m
 CONFIG_RT2400PCI=m