projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
33ae24f
)
ipsec{4,6} depend on kmod-crypto-aead to allow esp4 and esp6 to successfully load...
author
Florian Fainelli
<florian@openwrt.org>
Sat, 26 Jul 2008 18:24:59 +0000
(18:24 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Sat, 26 Jul 2008 18:24:59 +0000
(18:24 +0000)
SVN-Revision: 11942
package/kernel/modules/network.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/network.mk
b/package/kernel/modules/network.mk
index c4115a5c6c50ab383d125351e8cc7d0f59cc249e..5face2175b724dc411b443e0a4d4192bc4b56769 100644
(file)
--- a/
package/kernel/modules/network.mk
+++ b/
package/kernel/modules/network.mk
@@
-123,7
+123,7
@@
$(eval $(call KernelPackage,ipsec))
define KernelPackage/ipsec4
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=IPsec related modules (IPv4)
- DEPENDS:=kmod-ipsec +kmod-iptunnel4
+ DEPENDS:=kmod-ipsec +kmod-iptunnel4
+kmod-crypto-aead
KCONFIG:= \
CONFIG_INET_AH \
CONFIG_INET_ESP \
@@
-155,7
+155,7
@@
$(eval $(call KernelPackage,ipsec4))
define KernelPackage/ipsec6
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=IPsec related modules (IPv6)
- DEPENDS:=kmod-ipsec +kmod-iptunnel6
+ DEPENDS:=kmod-ipsec +kmod-iptunnel6
+kmod-crypto-aead
KCONFIG:= \
CONFIG_INET6_AH \
CONFIG_INET6_ESP \