arm-trusted-firmware-mediatek: only build bl2 for RAM boot images
authorDaniel Golle <daniel@makrotopia.org>
Fri, 16 Aug 2024 03:43:57 +0000 (04:43 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Fri, 16 Aug 2024 12:17:55 +0000 (13:17 +0100)
There is no need to build BL31 as anyway only the bl2 image is
relevant for use with mtk_uartboot. Build only bl2 in this case.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/boot/arm-trusted-firmware-mediatek/Makefile

index 91be8847570e32568159788f4f123df1ebc9cd50..d0529675680dde993840a182132e5b50e904e122 100644 (file)
@@ -547,7 +547,7 @@ TFA_MAKE_FLAGS += \
        $(if $(RAM_BOOT_UART_DL),RAM_BOOT_UART_DL=1) \
        $(if $(USE_UBI),UBI=1 $(if $(findstring mt7622,$(PLAT)),OVERRIDE_UBI_START_ADDR=0x80000)) \
        $(if $(USE_UBI),UBI=1 $(if $(findstring mt7981,$(PLAT)),OVERRIDE_UBI_START_ADDR=0x100000)) \
-       all
+       $(if $(RAM_BOOT_UART_DL),bl2,all)
 
 define Package/trusted-firmware-a-ram/install
        $(INSTALL_DIR) $(STAGING_DIR_IMAGE)