projects
/
openwrt
/
staging
/
florian.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d511e0d
)
kernel: Add kernel module package for LM70 temperature sensors
author
Florian Fainelli
<f.fainelli@gmail.com>
Sun, 11 Dec 2016 19:11:57 +0000
(11:11 -0800)
committer
Florian Fainelli
<f.fainelli@gmail.com>
Tue, 9 May 2017 03:41:56 +0000
(20:41 -0700)
Package the LM70 hwmon driver which supports a large number of LM70
compatible temperature sensors.
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
package/kernel/linux/modules/hwmon.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/hwmon.mk
b/package/kernel/linux/modules/hwmon.mk
index 79c81846c635479097589c8bffd360e6cea96442..1f00817904d5618395bbeda5e9c484bf11c50c9a 100644
(file)
--- a/
package/kernel/linux/modules/hwmon.mk
+++ b/
package/kernel/linux/modules/hwmon.mk
@@
-152,6
+152,21
@@
endef
$(eval $(call KernelPackage,hwmon-lm63))
+define KernelPackage/hwmon-lm70
+ TITLE:=LM70 monitoring support
+ KCONFIG:=CONFIG_SENSORS_LM70
+ FILES:=$(LINUX_DIR)/drivers/hwmon/lm70.ko
+ AUTOLOAD:=$(call AutoProbe,lm70)
+ $(call AddDepends/hwmon,)
+endef
+
+define KernelPackage/hwmon-lm70/description
+ Kernel module for lm70 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm70))
+
+
define KernelPackage/hwmon-lm75
TITLE:=LM75 monitoring support
KCONFIG:=CONFIG_SENSORS_LM75