armsr: v8: fix NVMEM_IMX_OCOTP_ELE build error
authorChristian Lamparter <chunkeey@gmail.com>
Sat, 15 Jul 2023 19:33:41 +0000 (21:33 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 15 Jul 2023 20:17:42 +0000 (22:17 +0200)
there's a new symbol NVMEM_IMX_OCOTP_ELE that needs to be defined.
otherwise the build will fail:

|  i.MX On-Chip OTP Controller support (NVMEM_IMX_OCOTP_ELE) [N/m/y/?] (NEW)
| make[6]: *** [scripts/kconfig/Makefile:77: syncconfig] Error 1
| make[5]: *** [Makefile:628: syncconfig] Error 2

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/armsr/armv8/config-5.15

index 54dd78a8aa1558a5a8a6d9ca13519d11d4441a3c..6b8b735059a94fba4cbc5f8cde76e5a29ce84eb0 100644 (file)
@@ -286,6 +286,7 @@ CONFIG_NR_CPUS=64
 CONFIG_NVIDIA_CARMEL_CNP_ERRATUM=y
 # CONFIG_NVMEM_IMX_IIM is not set
 CONFIG_NVMEM_IMX_OCOTP=y
+CONFIG_NVMEM_IMX_OCOTP_ELE=y
 CONFIG_NVMEM_IMX_OCOTP_SCU=y
 # CONFIG_NVMEM_LAYERSCAPE_SFP is not set
 CONFIG_NVMEM_ROCKCHIP_EFUSE=y