# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-# $Id: $
+# $Id$
include $(TOPDIR)/rules.mk
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://dansguardian.org/downloads/2/Beta
-PKG_MD5SUM:=
+PKG_MD5SUM:=7877ee4d34df6ac538e6522755cedaf6
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP = libtool
include $(INCLUDE_DIR)/package.mk
define Package/dansguardian
SECTION:=net
- DEPENDS:=+libpthread +uclibcxx
+ DEPENDS:=+libpthread +uclibcxx +zlib
CATEGORY:=Network
TITLE:=DansGuardian
URL:=http://dansguardian.org
LDFLAGS="$$$$LDFLAGS" \
LIBS="-nodefaultlibs -luClibc++ -lpthread" \
-
define Build/Configure
$(call Build/Configure/Default,\
--disable-clamav \
--with-sysconfsubdir=dansguardian \
--with-proxyuser=root \
--with-proxygroup=root \
+ --disable-pcre \
)
endef
---- dansguardian-2.9.9.2/configure 2007-11-13 17:17:03.000000000 +0100
-+++ dansguardian-2.9.9.2.new/configure 2008-02-21 11:15:07.000000000 +0100
+Index: dansguardian-2.9.9.2/configure
+===================================================================
+--- dansguardian-2.9.9.2.orig/configure 2008-02-27 17:52:06.000000000 +0100
++++ dansguardian-2.9.9.2/configure 2008-02-27 17:52:06.000000000 +0100
@@ -799,7 +799,7 @@
sharedstatedir='${prefix}/com'
localstatedir='${prefix}/var'