projects
/
openwrt
/
svn-archive
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a6cb5b8
)
brcm63xx image generation cleanups (#3169)
author
Florian Fainelli
<florian@openwrt.org>
Tue, 1 Apr 2008 21:10:47 +0000
(21:10 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Tue, 1 Apr 2008 21:10:47 +0000
(21:10 +0000)
SVN-Revision: 10703
target/linux/brcm63xx/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/brcm63xx/image/Makefile
b/target/linux/brcm63xx/image/Makefile
index 04231b4e855a7f4d46a1a5cafc0133162a6bbbfa..fab73efd20ca64a65defe64e1a77a8054fd72721 100644
(file)
--- a/
target/linux/brcm63xx/image/Makefile
+++ b/
target/linux/brcm63xx/image/Makefile
@@
-39,10
+39,15
@@
define Image/Prepare
TARGET="$(KDIR)" \
clean install
echo -ne "\\x00" >> $(KDIR)/loader.gz
+ rm -f $(KDIR)/fs_mark
+ touch $(KDIR)/fs_mark
+ $(call prepare_generic_squashfs,$(KDIR)/fs_mark)
endef
define Image/Build
+ifneq($(1),ext2)
$(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(1).trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
+endif
endef
$(eval $(call BuildImage))