projects
/
openwrt
/
staging
/
nbd.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a417bf9
)
image.mk: add Build step pad-to
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 15 Jun 2015 07:45:36 +0000
(07:45 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 15 Jun 2015 07:45:36 +0000
(07:45 +0000)
pad-to can be used in a pipe to pad the image to a specific chunk-size.
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
SVN-Revision: 45980
include/image.mk
patch
|
blob
|
history
diff --git
a/include/image.mk
b/include/image.mk
index 287c679cfd12d8cfdae0ddb46cfcdea6f7577f5b..814e7dc5d17f4e651af03e1c3aba307da4375cf2 100644
(file)
--- a/
include/image.mk
+++ b/
include/image.mk
@@
-304,6
+304,11
@@
define Build/append-rootfs
dd if=$(word 2,$^) $(if $(1),bs=$(1) conv=sync) >> $@
endef
+define Build/pad-to
+ dd if=$@ of=$@.new bs=$(1) conv=sync
+ mv $@.new $@
+endef
+
define Build/pad-rootfs
$(call prepare_generic_squashfs,$@ $(1))
endef