convert lighttpd and net-snmp to use autoconf_bool for ipv6
authorFlorian Fainelli <florian@openwrt.org>
Sat, 29 Jan 2011 22:09:19 +0000 (22:09 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 29 Jan 2011 22:09:19 +0000 (22:09 +0000)
SVN-Revision: 25248

net/lighttpd/Makefile
net/net-snmp/Makefile

index 9b344cce5a0fd658462f8dc35d055f64cc6f244f..0eebabcc304b23a076e4981011c66a09ed05b458 100644 (file)
@@ -225,15 +225,11 @@ CONFIGURE_ARGS+= \
        --with-openssl="$(STAGING_DIR)/usr" \
        --with-pcre \
        --without-valgrind \
+        $(call autoconf_bool,CONFIG_IPV6,ipv6)
 
 CONFIGURE_VARS+= \
        PCRE_LIB="-lpcre" \
 
-ifeq ($(CONFIG_IPV6),y)
-  CONFIGURE_ARGS+= \
-       --enable-ipv6
-endif
-
 ifneq ($(SDK)$(CONFIG_PACKAGE_lighttpd-mod-webdav),)
   CONFIGURE_ARGS+= \
        --with-webdav-locks \
index d4b1227c4e9c088d619daedde03dbc06d298ef8a..51742a22ec47a9623a7e8a47c40b962f4034fa81 100644 (file)
@@ -172,10 +172,10 @@ CONFIGURE_ARGS += \
        --without-libwrap \
        --without-rpm \
        --without-zlib \
+        $(call autoconf_bool,CONFIG_IPV6,ipv6) \
 
 ifeq ($(CONFIG_IPV6),y)
 SNMP_TRANSPORTS_INCLUDED+= UDPIPv6
-CONFIGURE_ARGS+= --enable-ipv6
 endif
 
 TARGET_LDFLAGS += -L$(TOOLCHAIN_DIR)/usr/lib