projects
/
openwrt
/
staging
/
xback.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
25d318e
)
only define unpack templates if PKG_SOURCE is set
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 22 Feb 2009 18:27:53 +0000
(18:27 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 22 Feb 2009 18:27:53 +0000
(18:27 +0000)
SVN-Revision: 14623
include/unpack.mk
patch
|
blob
|
history
diff --git
a/include/unpack.mk
b/include/unpack.mk
index ae8cdecb271ef1e760df78e365209a4cf4439c00..e2810944e83a0ef22e0230833acff7cdaaee0e6b 100644
(file)
--- a/
include/unpack.mk
+++ b/
include/unpack.mk
@@
-16,7
+16,8
@@
UNZIP_CMD=unzip -d $(1)/.. $(DL_DIR)/$(PKG_SOURCE)
ifeq ($(PKG_SOURCE),)
PKG_UNPACK ?= true
-endif
+else
+
ifeq ($(strip $(UNPACK_CMD)),)
ifeq ($(strip $(PKG_CAT)),)
# try to autodetect file type
@@
-64,9
+65,13
@@
ifeq ($(strip $(UNPACK_CMD)),)
CRLF_CMD :=
endif
endif
+
ifdef PKG_BUILD_DIR
PKG_UNPACK := $(call UNPACK_CMD,$(PKG_BUILD_DIR)) $(call CRLF_CMD,$(PKG_BUILD_DIR))
endif
ifdef HOST_BUILD_DIR
HOST_UNPACK := $(call UNPACK_CMD,$(HOST_BUILD_DIR)) $(call CRLF_CMD,$(HOST_BUILD_DIR))
endif
+
+endif # PKG_SOURCE
+