libftdi: fix build for x86_64 target
authorFlorian Fainelli <florian@openwrt.org>
Tue, 20 May 2014 04:51:37 +0000 (04:51 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 20 May 2014 04:51:37 +0000 (04:51 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 40792

libs/libftdi/Makefile
libs/libftdi/patches/100-fix-x86_64-build.patch [new file with mode: 0644]

index 819c03672b4c58c5e7081c558d9c2b66f6342255..7bf5b2b6f4ab0148165628011ae6ca497bb0675e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libftdi
 PKG_VERSION:=0.19
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.intra2net.com/en/developer/libftdi/download/
diff --git a/libs/libftdi/patches/100-fix-x86_64-build.patch b/libs/libftdi/patches/100-fix-x86_64-build.patch
new file mode 100644 (file)
index 0000000..9a9da9a
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -43,7 +43,7 @@ IF(CMAKE_SIZEOF_VOID_P EQUAL 4)
+     SET(LIB_SUFFIX "")
+     SET(PACK_ARCH "")
+   ELSE(CMAKE_SIZEOF_VOID_P EQUAL 8)
+-    SET(LIB_SUFFIX 64)
++    SET(LIB_SUFFIX "")
+     SET(PACK_ARCH .x86_64)
+ endif(CMAKE_SIZEOF_VOID_P EQUAL 4)