FIXME: toolchain/Makefile: do not ever remove any toolchain again
authorPetr Štetiar <ynezz@true.cz>
Tue, 29 Mar 2022 02:38:21 +0000 (04:38 +0200)
committerPetr Štetiar <ynezz@true.cz>
Thu, 25 Aug 2022 20:08:13 +0000 (22:08 +0200)
Something is really not working as expected

Signed-off-by: Petr Štetiar <ynezz@true.cz>
toolchain/Makefile

index 5dccf8f82906b58ba1f2c406eb01742a1a9084d2..ea9b6d8955b45198151cbbcff6628808f4b34a9e 100644 (file)
@@ -66,20 +66,6 @@ ifneq ($(ARCH),)
 endif
 endif
 
-ifdef CONFIG_BUILDBOT
-ifneq ($(wildcard $(TOPDIR)/.git),)
-  $(TOOLCHAIN_DIR)/stamp/.ver_check: $(TMP_DIR)/.build
-       cd "$(TOPDIR)"; git log --format=%h -1 toolchain > $(TMP_DIR)/.ver_check
-       cmp -s $(TMP_DIR)/.ver_check $@ || { \
-               rm -rf $(BUILD_DIR) $(STAGING_DIR) $(TOOLCHAIN_DIR) $(BUILD_DIR_TOOLCHAIN); \
-               mkdir -p $(TOOLCHAIN_DIR)/stamp; \
-               mv $(TMP_DIR)/.ver_check $@; \
-       }
-
-$(TOOLCHAIN_DIR)/info.mk $(STAGING_DIR)/.prepared: $(TOOLCHAIN_DIR)/stamp/.ver_check
-endif
-endif
-
 # prerequisites for the individual targets
 $(curdir)/ := .config prereq
 $(curdir)//compile = $(STAGING_DIR)/.prepared $(TOOLCHAIN_DIR)/info.mk $(tools/stamp-compile)