tools: fakeroot: update to 1.36
authorShiji Yang <yangshiji66@qq.com>
Fri, 27 Sep 2024 10:15:16 +0000 (18:15 +0800)
committerNick Hainke <vincent@systemli.org>
Sat, 28 Sep 2024 08:27:41 +0000 (10:27 +0200)
The type 'id_t' check has been moved to configure.ac in upstream commit:
819063eb4d27 ("test for id_t with autoconf instead of blind typedef, fixes FTBFS on FreeBSD")

changelog:
https://salsa.debian.org/clint/fakeroot/-/blob/e4780b1aad6fae0be1868a76cc7ffa6149afa912/debian/changelog

Signed-off-by: Shiji Yang <yangshiji66@qq.com>
Link: https://github.com/openwrt/openwrt/pull/16530
Signed-off-by: Nick Hainke <vincent@systemli.org>
tools/fakeroot/Makefile
tools/fakeroot/patches/300-time64-hack.patch
tools/fakeroot/patches/400-alpine-libc.musl-fix.patch

index 699675bdc355212b59169a8fb40bc4db88265894..22b2c8f24f5d24570cdfc9f974e600fc5745c91e 100644 (file)
@@ -5,12 +5,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fakeroot
-PKG_VERSION:=1.33
+PKG_VERSION:=1.36
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=@DEBIAN/pool/main/f/fakeroot
-PKG_HASH:=e157d8e5c64d3a755707791e9be93296c6d249d5c4478bf941b675d49c47757d
+PKG_HASH:=7fe3cf3daf95ee93b47e568e85f4d341a1f9ae91766b4f9a9cdc29737dea4988
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_LICENSE_FILES:=COPYING
 PKG_FIXUP:=autoreconf
index 540724fb5a856ca6facf07cb6ed5031df82c0693..46132cdd3d0878f64864f27f80cead4e0b118efd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -386,7 +386,7 @@ dnl  Digital Unix: stat
+@@ -390,7 +390,7 @@ dnl  Digital Unix: stat
  time64_hack=no
  AH_TEMPLATE([TIME64_HACK], [time64 shuffle])
  AC_MSG_CHECKING([if we need to cope with time64])
index f740b120a14eac8f61fa77d2f5eab856a9f0cbee..59360349113b37787b67655df435e3fa97502b2b 100644 (file)
@@ -21,14 +21,3 @@ Error relocating openwrt/staging_dir/host/lib/libfakeroot.so: SEND_GET_XATTR: sy
  #define SEND_GET_XATTR64(a,b,c) send_get_xattr64(a,b)
  #endif
  
-@@ -142,8 +144,9 @@
- /* 10.10 uses id_t in getpriority/setpriority calls, so pretend
-    id_t is used everywhere, just happens to be int on some OSes */
--#ifndef _ID_T
-+#if !defined(_ID_T) && !defined(__DEFINED_id_t)
- #define _ID_T
-+#define __DEFINED_id_t
- typedef int id_t;
- #endif
- #endif