[packages] collectd: fix iwinfo station count (#11639)
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 10 Jun 2012 18:34:54 +0000 (18:34 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 10 Jun 2012 18:34:54 +0000 (18:34 +0000)
SVN-Revision: 32167

utils/collectd/Makefile
utils/collectd/patches/900-add-iwinfo-plugin.patch

index 5a2176119c958b62e92444104242bba1dfb88f4b..eac9b2acaaabede41b2e8fb68031ebfc44e8c222 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=collectd
 PKG_VERSION:=4.10.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://collectd.org/files/
index 40618f0a67593f271901e146aec6cc31fbf49932..98945863c18ffe014b2278994ed91d94c8ccf5d8 100644 (file)
@@ -97,7 +97,7 @@
  The I<Java> plugin makes it possible to write extensions for collectd in Java.
 --- /dev/null
 +++ b/src/iwinfo.c
-@@ -0,0 +1,149 @@
+@@ -0,0 +1,150 @@
 +/**
 + * collectd - src/iwinfo.c
 + * Copyright (C) 2011  Jo-Philipp Wich
 +
 +              if (iw->assoclist(ifname, buf, &val))
 +                      val = 0;
-+              iwinfo_submit(ifname, "stations", val);
++              iwinfo_submit(ifname, "stations",
++                            val / sizeof(struct iwinfo_assoclist_entry));
 +      }
 +
 +      iwinfo_finish();