ath79: disable building future NAND images for GL-AR300M/GL-AR750S
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 7 Nov 2019 17:53:37 +0000 (18:53 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 7 Nov 2019 18:06:57 +0000 (19:06 +0100)
To simplify the upgrade process and ensure easier identification of
device partitioning, the following devices are disabled on ath79
target in openwrt-19.07 branch:

- glinet,gl-ar300m-nor
- glinet,gl-ar300m-nand
- glinet,gl-ar750s

Proper ath79 (NAND) support for the devices is expected to be
introduced based on kernel 4.19 (see GitHub PR #2184).

In openwrt-19.07, ar71xx should be used for those devices.

With this, we ensure that the new ath79 image names (at least for
releases) refer to the updated partitioning.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/image/generic.mk
target/linux/ath79/image/nand.mk

index 3b7fdb7015fe753be5cf748cd0b78208f2030e30..625c2bdd0500ce67a00dc4177e5ce94135d10aab 100644 (file)
@@ -395,7 +395,7 @@ define Device/glinet_gl-ar300m-nor
   $(Device/glinet_gl-ar300m-common-nor)
   DEVICE_TITLE := GL.iNet GL-AR300M
 endef
-TARGET_DEVICES += glinet_gl-ar300m-nor
+#TARGET_DEVICES += glinet_gl-ar300m-nor
 
 define Device/glinet_gl-ar750s
   ATH_SOC := qca9563
@@ -404,7 +404,7 @@ define Device/glinet_gl-ar750s
   IMAGE_SIZE := 16000k
   SUPPORTED_DEVICES += gl-ar750s
 endef
-TARGET_DEVICES += glinet_gl-ar750s
+#TARGET_DEVICES += glinet_gl-ar750s
 
 define Device/glinet_gl-x750
   ATH_SOC := qca9531
index eee419194ba751cb3ba3eafd7f5da5e647eba91a..0b5c05f8cbd6cc49825ba495c0c891802fc9f1f7 100644 (file)
@@ -10,4 +10,4 @@ define Device/glinet_gl-ar300m-nand
   IMAGE/sysupgrade.bin := sysupgrade-tar
   IMAGE/factory.ubi := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
 endef
-TARGET_DEVICES += glinet_gl-ar300m-nand
+#TARGET_DEVICES += glinet_gl-ar300m-nand