projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
75f55a6
)
Make ide-core depend on pci support, remove dupe Kconfig item
author
Nicolas Thill
<nico@openwrt.org>
Sun, 31 Aug 2008 21:27:38 +0000
(21:27 +0000)
committer
Nicolas Thill
<nico@openwrt.org>
Sun, 31 Aug 2008 21:27:38 +0000
(21:27 +0000)
SVN-Revision: 12448
package/kernel/modules/block.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/block.mk
b/package/kernel/modules/block.mk
index bf327e1696e2bbff3d722ef07a45f59528ecb429..cc8398335c80abc5f7a5f8503d1fd3d98bc81778 100644
(file)
--- a/
package/kernel/modules/block.mk
+++ b/
package/kernel/modules/block.mk
@@
-116,12
+116,12
@@
$(eval $(call KernelPackage,ata-via-sata))
define KernelPackage/ide-core
SUBMENU:=$(BLOCK_MENU)
TITLE:=IDE (ATA/ATAPI) device support
+ DEPENDS:=@PCI_SUPPORT
KCONFIG:= \
CONFIG_IDE \
CONFIG_IDE_GENERIC \
CONFIG_BLK_DEV_GENERIC \
CONFIG_BLK_DEV_IDE \
- CONFIG_IDE_GENERIC \
CONFIG_BLK_DEV_IDEDISK \
CONFIG_BLK_DEV_IDEDMA_PCI=y \
CONFIG_BLK_DEV_IDEPCI=y