ASoC: Intel: common: add ACPI matching tables for Tiger Lake
authorPan Xiuli <xiuli.pan@linux.intel.com>
Thu, 15 Aug 2019 15:57:46 +0000 (10:57 -0500)
committerMark Brown <broonie@kernel.org>
Thu, 15 Aug 2019 17:12:42 +0000 (18:12 +0100)
Initial support for TGL w/ RT1308

Signed-off-by: Pan Xiuli <xiuli.pan@linux.intel.com>
Signed-off-by: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>
Link: https://lore.kernel.org/r/20190815155749.29304-2-pierre-louis.bossart@linux.intel.com
Signed-off-by: Mark Brown <broonie@kernel.org>
include/sound/soc-acpi-intel-match.h
sound/soc/intel/common/Makefile
sound/soc/intel/common/soc-acpi-intel-tgl-match.c [new file with mode: 0644]

index bb5e1e4ce8bf915eb8d449a97ecd4075a0f5fa25..ce6c4a97093997c9c4fcf8b8b7c185a0afbeda4d 100644 (file)
@@ -25,6 +25,7 @@ extern struct snd_soc_acpi_mach snd_soc_acpi_intel_bxt_machines[];
 extern struct snd_soc_acpi_mach snd_soc_acpi_intel_glk_machines[];
 extern struct snd_soc_acpi_mach snd_soc_acpi_intel_cnl_machines[];
 extern struct snd_soc_acpi_mach snd_soc_acpi_intel_icl_machines[];
+extern struct snd_soc_acpi_mach snd_soc_acpi_intel_tgl_machines[];
 
 /*
  * generic table used for HDA codec-based platforms, possibly with
index 56c81e20b5bf8d617a48cd59e02e2cbf58dfc169..a14aca62ff9671cb67896a451c31d4470e53471b 100644 (file)
@@ -8,6 +8,7 @@ snd-soc-acpi-intel-match-objs := soc-acpi-intel-byt-match.o soc-acpi-intel-cht-m
        soc-acpi-intel-skl-match.o soc-acpi-intel-kbl-match.o \
        soc-acpi-intel-bxt-match.o soc-acpi-intel-glk-match.o \
        soc-acpi-intel-cnl-match.o soc-acpi-intel-icl-match.o \
+       soc-acpi-intel-tgl-match.o \
        soc-acpi-intel-hda-match.o
 
 obj-$(CONFIG_SND_SOC_INTEL_SST) += snd-soc-sst-dsp.o snd-soc-sst-ipc.o
diff --git a/sound/soc/intel/common/soc-acpi-intel-tgl-match.c b/sound/soc/intel/common/soc-acpi-intel-tgl-match.c
new file mode 100644 (file)
index 0000000..57a6298
--- /dev/null
@@ -0,0 +1,24 @@
+// SPDX-License-Identifier: GPL-2.0
+/*
+ * soc-apci-intel-tgl-match.c - tables and support for ICL ACPI enumeration.
+ *
+ * Copyright (c) 2019, Intel Corporation.
+ *
+ */
+
+#include <sound/soc-acpi.h>
+#include <sound/soc-acpi-intel-match.h>
+
+struct snd_soc_acpi_mach snd_soc_acpi_intel_tgl_machines[] = {
+       {
+               .id = "10EC1308",
+               .drv_name = "tgl_rt1308",
+               .sof_fw_filename = "sof-tgl.ri",
+               .sof_tplg_filename = "sof-tgl-rt1308.tplg",
+       },
+       {},
+};
+EXPORT_SYMBOL_GPL(snd_soc_acpi_intel_tgl_machines);
+
+MODULE_LICENSE("GPL v2");
+MODULE_DESCRIPTION("Intel Common ACPI Match module");