[packages_10.03.2] privoxy: merge r29151, r29805
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 15:56:03 +0000 (15:56 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 15:56:03 +0000 (15:56 +0000)
SVN-Revision: 30241

net/privoxy/Makefile
net/privoxy/files/privoxy.init

index 2cc6bff646f499a8320fd7bcb3834e9e6f6cbf58..e4b45cf76e32ab2419f03a38b407ad0552c278f5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=privoxy
-PKG_VERSION:=3.0.17
-PKG_RELEASE:=2
+PKG_VERSION:=3.0.19
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz
 PKG_SOURCE_URL:=@SF/ijbswa
-PKG_MD5SUM:=9d363d738a3f3d73e774d6dfeafdb15f
+PKG_MD5SUM:=57acc79059565cc42eda67982842785d
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-stable
 PKG_FIXUP:=autoreconf
index 85479b33829e088df346b72adce3d7c4b46da76e..0afe4c49025518d4ef54b93c90a2713c1bb58e4b 100644 (file)
@@ -1,16 +1,16 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=50
+STOP=50
 
-CFG_F=/etc/privoxy/config
-RUN_D=/var/run
-PID_F=$RUN_D/privoxy.pid
+SERVICE_USE_PID=1
 
 start() {
-       mkdir -p $RUN_D
-       /usr/sbin/privoxy --pidfile $PID_F $CFG_F
+       service_start /usr/sbin/privoxy --pidfile /var/run/privoxy.pid \
+                                       /etc/privoxy/config
 }
 
 stop() {
-       [ -f $PID_F ] && kill $(cat $PID_F)
+       service_stop /usr/sbin/privoxy
 }