ramips: mt7621: add support for Cudy X6 v2
authorFelix Baumann <felix.bau@gmx.de>
Fri, 21 Apr 2023 01:39:38 +0000 (03:39 +0200)
committerDavid Bauer <mail@david-bauer.net>
Wed, 3 May 2023 22:07:11 +0000 (00:07 +0200)
Rename existing device to v1 and create common .dtsi
Difference to v1: 16MB Flash

Specifications:

SoC: MediaTek MT7621
RAM: 256 MB
Flash: 16 MB (SPI NOR, XM25QH128C on my device)
WiFi: MediaTek MT7915E
Switch: 1 WAN, 4 LAN (Gigabit)
Buttons: Reset, WPS
LEDs: Two Power LEDs (blue and red; together they form purple)
Power: DC 12V 1A center positive
Serial: 115200 8N1
        C440 - (3V3 - GND - RX - TX) - C41 | v1 and v2
               (P   - G   - R  - T)        | v2 labels them on the board
Installation:

Download and flash the manufacturer's built OpenWrt image available at
http://www.cudytech.com/openwrt_software_download
Install the new OpenWrt image via luci (System -> Backup/Flash firmware)
Be sure to NOT keep settings.

Recovery:

Loads only signed manufacture firmware due to bootloader RSA verification
Serve tftp-recovery image as /recovery.bin on 192.168.1.88/24
Connect to any lan ethernet port
Power on the device while holding the reset button
Wait at least 8 seconds before releasing reset button for image to
download

MAC addresses as verified by OEM firmware:

use   address             source
LAN   f4:a4:54:86:75:a2   label
WAN   f4:a4:54:86:75:a3   label + 1
2g    f4:a4:54:86:75:a2   label
5g    f6:a4:54:b6:75:a2   label + LA-Bit set + 4th oktet increased

The label MAC address is found in bdinfo 0xde00.

Signed-off-by: Felix Baumann <felix.bau@gmx.de>
(cherry picked from commit e38de40f8dd350344407fe5a91e81191f6960804)

target/linux/ramips/dts/mt7621_cudy_x6-v1.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7621_cudy_x6-v2.dts [new file with mode: 0644]
target/linux/ramips/dts/mt7621_cudy_x6.dts [deleted file]
target/linux/ramips/dts/mt7621_cudy_x6.dtsi [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk
target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac

diff --git a/target/linux/ramips/dts/mt7621_cudy_x6-v1.dts b/target/linux/ramips/dts/mt7621_cudy_x6-v1.dts
new file mode 100644 (file)
index 0000000..78a4504
--- /dev/null
@@ -0,0 +1,62 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621_cudy_x6.dtsi"
+
+/ {
+       compatible = "cudy,x6-v1", "mediatek,mt7621-soc";
+       model = "CUDY X6 v1";
+};
+
+&partitions {
+       partition@50000 {
+               compatible = "denx,uimage";
+               label = "firmware";
+               reg = <0x50000 0x1f80000>;
+       };
+
+       partition@1fd0000 {
+               label = "debug";
+               reg = <0x1fd0000 0x10000>;
+               read-only;
+       };
+
+       partition@1fe0000 {
+               label = "backup";
+               reg = <0x1fe0000 0x10000>;
+               read-only;
+       };
+
+       partition@1ff0000 {
+               label = "bdinfo";
+               reg = <0x1ff0000 0x10000>;
+               read-only;
+
+               compatible = "nvmem-cells";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               macaddr_bdinfo_de00: macaddr@de00 {
+                       reg = <0xde00 0x6>;
+               };
+       };
+};
+
+&gmac0 {
+       nvmem-cells = <&macaddr_bdinfo_de00>;
+       nvmem-cell-names = "mac-address";
+};
+
+&switch0 {
+       ports {
+               port@4 {
+                       nvmem-cells = <&macaddr_bdinfo_de00>;
+                       nvmem-cell-names = "mac-address";
+                       mac-address-increment = <1>;
+               };
+       };
+};
+
+&wifi {
+       nvmem-cells = <&macaddr_bdinfo_de00>;
+       nvmem-cell-names = "mac-address";
+};
diff --git a/target/linux/ramips/dts/mt7621_cudy_x6-v2.dts b/target/linux/ramips/dts/mt7621_cudy_x6-v2.dts
new file mode 100644 (file)
index 0000000..aa36688
--- /dev/null
@@ -0,0 +1,62 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621_cudy_x6.dtsi"
+
+/ {
+       compatible = "cudy,x6-v2", "mediatek,mt7621-soc";
+       model = "CUDY X6 v2";
+};
+
+&partitions {
+       partition@50000 {
+               compatible = "denx,uimage";
+               label = "firmware";
+               reg = <0x50000 0xf80000>;
+       };
+
+       partition@fd0000 {
+               label = "debug";
+               reg = <0xfd0000 0x10000>;
+               read-only;
+       };
+
+       partition@fe0000 {
+               label = "backup";
+               reg = <0xfe0000 0x10000>;
+               read-only;
+       };
+
+       partition@ff0000 {
+               label = "bdinfo";
+               reg = <0xff0000 0x10000>;
+               read-only;
+
+               compatible = "nvmem-cells";
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               macaddr_bdinfo_de00: macaddr@de00 {
+                       reg = <0xde00 0x6>;
+               };
+       };
+};
+
+&gmac0 {
+       nvmem-cells = <&macaddr_bdinfo_de00>;
+       nvmem-cell-names = "mac-address";
+};
+
+&switch0 {
+       ports {
+               port@4 {
+                       nvmem-cells = <&macaddr_bdinfo_de00>;
+                       nvmem-cell-names = "mac-address";
+                       mac-address-increment = <1>;
+               };
+       };
+};
+
+&wifi {
+       nvmem-cells = <&macaddr_bdinfo_de00>;
+       nvmem-cell-names = "mac-address";
+};
diff --git a/target/linux/ramips/dts/mt7621_cudy_x6.dts b/target/linux/ramips/dts/mt7621_cudy_x6.dts
deleted file mode 100644 (file)
index dc21964..0000000
+++ /dev/null
@@ -1,179 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "mt7621.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-/ {
-       compatible = "cudy,x6", "mediatek,mt7621-soc";
-       model = "CUDY X6";
-
-       aliases {
-               led-boot = &led_internet_blue;
-               led-failsafe = &led_internet_red;
-               led-running = &led_internet_blue;
-               led-upgrade = &led_internet_red;
-               label-mac-device = &gmac0;
-       };
-
-       chosen {
-               bootargs = "console=ttyS0,115200";
-       };
-
-       keys {
-               compatible = "gpio-keys";
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-
-               wps {
-                       label = "wps";
-                       gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_WPS_BUTTON>;
-               };
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               led_internet_blue: internet_blue {
-                       label = "blue:internet";
-                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
-               };
-
-               led_internet_red: internet_red {
-                       label = "red:internet";
-                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
-               };
-       };
-
-};
-
-&spi0 {
-       status = "okay";
-
-       flash@0 {
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <50000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x0 0x30000>;
-                               read-only;
-                       };
-
-                       partition@30000 {
-                               label = "u-boot-env";
-                               reg = <0x30000 0x10000>;
-                               read-only;
-                       };
-
-                       factory: partition@40000 {
-                               label = "factory";
-                               reg = <0x40000 0x10000>;
-                               read-only;
-                       };
-
-                       partition@50000 {
-                               compatible = "denx,uimage";
-                               label = "firmware";
-                               reg = <0x50000 0x1f80000>;
-                       };
-
-                       partition@1fd0000 {
-                               label = "debug";
-                               reg = <0x1fd0000 0x10000>;
-                               read-only;
-                       };
-
-                       partition@1fe0000 {
-                               label = "backup";
-                               reg = <0x1fe0000 0x10000>;
-                               read-only;
-                       };
-
-                       partition@1ff0000 {
-                               label = "bdinfo";
-                               reg = <0x1ff0000 0x10000>;
-                               read-only;
-
-                               compatible = "nvmem-cells";
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-
-                               macaddr_bdinfo_de00: macaddr@de00 {
-                                       reg = <0xde00 0x6>;
-                               };
-                       };
-               };
-       };
-};
-
-&pcie {
-       status = "okay";
-};
-
-&pcie1 {
-       wifi@0,0 {
-               compatible = "mediatek,mt76";
-               reg = <0x0000 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x0000>;
-
-               nvmem-cells = <&macaddr_bdinfo_de00>;
-               nvmem-cell-names = "mac-address";
-       };
-};
-
-&gmac0 {
-       nvmem-cells = <&macaddr_bdinfo_de00>;
-       nvmem-cell-names = "mac-address";
-};
-
-&switch0 {
-       ports {
-               port@0 {
-                       status = "okay";
-                       label = "lan1";
-               };
-
-               port@1 {
-                       status = "okay";
-                       label = "lan2";
-               };
-
-               port@2 {
-                       status = "okay";
-                       label = "lan3";
-               };
-
-               port@3 {
-                       status = "okay";
-                       label = "lan4";
-               };
-
-               port@4 {
-                       status = "okay";
-                       label = "wan";
-                       nvmem-cells = <&macaddr_bdinfo_de00>;
-                       nvmem-cell-names = "mac-address";
-                       mac-address-increment = <1>;
-               };
-       };
-};
-
-&state_default {
-       gpio {
-               groups = "uart3", "jtag";
-               function = "gpio";
-       };
-};
diff --git a/target/linux/ramips/dts/mt7621_cudy_x6.dtsi b/target/linux/ramips/dts/mt7621_cudy_x6.dtsi
new file mode 100644 (file)
index 0000000..2055d2a
--- /dev/null
@@ -0,0 +1,135 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       aliases {
+               led-boot = &led_internet_blue;
+               led-failsafe = &led_internet_red;
+               led-running = &led_internet_blue;
+               led-upgrade = &led_internet_red;
+               label-mac-device = &gmac0;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_internet_blue: internet_blue {
+                       label = "blue:internet";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               };
+
+               led_internet_red: internet_red {
+                       label = "red:internet";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <50000000>;
+
+               partitions: partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@40000 {
+                               label = "factory";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+                       };
+
+                       /* additional partitions in DTS */
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie1 {
+       wifi:wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x0000>;
+       };
+};
+
+&switch0 {
+       ports {
+               port@0 {
+                       status = "okay";
+                       label = "lan1";
+               };
+
+               port@1 {
+                       status = "okay";
+                       label = "lan2";
+               };
+
+               port@2 {
+                       status = "okay";
+                       label = "lan3";
+               };
+
+               port@3 {
+                       status = "okay";
+                       label = "lan4";
+               };
+
+               port@4 {
+                       status = "okay";
+                       label = "wan";
+               };
+       };
+};
+
+&state_default {
+       gpio {
+               groups = "uart3", "jtag";
+               function = "gpio";
+       };
+};
index 3bf9fd3eda8bdc20b09ad9cb6cb3376bc0ca7513..ab0ff95f7529aa43e69e67a4e3a303242c9b2605 100644 (file)
@@ -345,16 +345,29 @@ define Device/cudy_wr2100
 endef
 TARGET_DEVICES += cudy_wr2100
 
-define Device/cudy_x6
+define Device/cudy_x6-v1
   $(Device/dsa-migration)
   IMAGE_SIZE := 32256k
   DEVICE_VENDOR := Cudy
   DEVICE_MODEL := X6
+  DEVICE_VARIANT := v1
   UIMAGE_NAME := R13
   DEVICE_PACKAGES := kmod-mt7915e
-  SUPPORTED_DEVICES += R13
+  SUPPORTED_DEVICES += cudy,x6 R13
+endef
+TARGET_DEVICES += cudy_x6-v1
+
+define Device/cudy_x6-v2
+  $(Device/dsa-migration)
+  IMAGE_SIZE := 15872k
+  DEVICE_VENDOR := Cudy
+  DEVICE_MODEL := X6
+  DEVICE_VARIANT := v2
+  UIMAGE_NAME := R30
+  DEVICE_PACKAGES := kmod-mt7915e
+  SUPPORTED_DEVICES += cudy,x6 R30
 endef
-TARGET_DEVICES += cudy_x6
+TARGET_DEVICES += cudy_x6-v2
 
 define Device/dlink_dap-x1860-a1
   $(Device/dsa-migration)
index b4d7542179369ede56175dcadc0e5b2d3c2cb1c1..d8bd067733a6dba8e63fec579361f9f597d2bea9 100644 (file)
@@ -18,7 +18,8 @@ case "$board" in
                hw_mac_addr=$(macaddr_unsetbit $hw_mac_addr 28)
                [ "$PHYNBR" = "1" ] && macaddr_setbit_la $hw_mac_addr > /sys${DEVPATH}/macaddress
                ;;
-       cudy,x6)
+       cudy,x6-v1|\
+       cudy,x6-v2)
                hw_mac_addr="$(mtd_get_mac_binary bdinfo 0xde00)"
                [ "$PHYNBR" = "1" ] && \
                macaddr_setbit_la "$(macaddr_add $hw_mac_addr 0x100000)" > /sys${DEVPATH}/macaddress