projects
/
openwrt
/
staging
/
nbd.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
140f6cc
)
Prevent SSH keys from being chmoded to 644 (#664), looks like those are the only...
author
Florian Fainelli
<florian@openwrt.org>
Sun, 15 Oct 2006 23:03:46 +0000
(23:03 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Sun, 15 Oct 2006 23:03:46 +0000
(23:03 +0000)
SVN-Revision: 5135
include/image.mk
patch
|
blob
|
history
diff --git
a/include/image.mk
b/include/image.mk
index 06516791805b082711a321d483977c675d976ad7..c738146851d58b2ae2709ddb9c16a1b487ba9b8d 100644
(file)
--- a/
include/image.mk
+++ b/
include/image.mk
@@
-57,7
+57,7
@@
endif
define Image/mkfs/prepare/default
- find $(BUILD_DIR)/root -type f -not -perm +0100 | xargs chmod 0644
+ find $(BUILD_DIR)/root -type f -not -perm +0100
-not -name 'ssh_host*'
| xargs chmod 0644
find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
find $(BUILD_DIR)/root -type d | xargs chmod 0755
mkdir -p $(BUILD_DIR)/root/tmp