projects
/
openwrt
/
staging
/
neocturne.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
e3a1d3b
)
mbedtls: build with PIC
author
Rosen Penev
<rosenp@gmail.com>
Sat, 9 Jul 2022 03:50:44 +0000
(20:50 -0700)
committer
Christian Lamparter
<chunkeey@gmail.com>
Sun, 17 Jul 2022 11:43:48 +0000
(13:43 +0200)
Fixes compilation with GCC12 and dependent packages for some reason.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/libs/mbedtls/Makefile
patch
|
blob
|
history
diff --git
a/package/libs/mbedtls/Makefile
b/package/libs/mbedtls/Makefile
index 9c6c81d9c1d0e012a3506cfe9e65c42a087c903d..b6dc584403bbb24e880088a687a56a521abed0f5 100644
(file)
--- a/
package/libs/mbedtls/Makefile
+++ b/
package/libs/mbedtls/Makefile
@@
-91,6
+91,7
@@
TARGET_CFLAGS += -ffunction-sections -fdata-sections
TARGET_CFLAGS := $(filter-out -O%,$(TARGET_CFLAGS))
CMAKE_OPTIONS += \
+ -DCMAKE_POSITION_INDEPENDENT_CODE=ON \
-DUSE_SHARED_MBEDTLS_LIBRARY:Bool=ON \
-DENABLE_TESTING:Bool=OFF \
-DENABLE_PROGRAMS:Bool=ON