projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
717bbc3
)
kernel: DSA is missing a OF dependend dep for mdio
author
John Crispin
<john@openwrt.org>
Tue, 16 Feb 2016 16:25:25 +0000
(16:25 +0000)
committer
John Crispin
<john@openwrt.org>
Tue, 16 Feb 2016 16:25:25 +0000
(16:25 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 48727
package/kernel/linux/modules/dsa.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/dsa.mk
b/package/kernel/linux/modules/dsa.mk
index 5f19a3f7b4ceb2d8eaa5d2589fa54b95949dfbe1..72dd93513c252bed55262297d8321d4997a6cb04 100644
(file)
--- a/
package/kernel/linux/modules/dsa.mk
+++ b/
package/kernel/linux/modules/dsa.mk
@@
-19,6
+19,9
@@
define KernelPackage/dsa
CONFIG_NET_SWITCHDEV=y \
CONFIG_NET_DSA_HWMON=n
DEPENDS:=+kmod-libphy
+ifeq ($(CONFIG_OF),y)
+ DEPENDS+=+kmod-of-mdio
+endif
FILES:=$(LINUX_DIR)/net/dsa/dsa_core.ko
AUTOLOAD:=$(call AutoLoad,34,dsa_core)
endef