projects
/
openwrt
/
staging
/
neocturne.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
cf440ae
)
gcc: build with HOST_CFLAGS
author
Florian Fainelli
<florian@openwrt.org>
Mon, 19 Nov 2012 23:12:00 +0000
(23:12 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Mon, 19 Nov 2012 23:12:00 +0000
(23:12 +0000)
Turns on -O2 optimization when building GCC thus making the cross-compiler a
little faster (about 25%).
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 34266
toolchain/gcc/common.mk
patch
|
blob
|
history
diff --git
a/toolchain/gcc/common.mk
b/toolchain/gcc/common.mk
index 6e4c61214b1465e24931a7e9e8703129695d3728..924ed90a63eb4b7cdc4e4cdd651d35a667038a92 100644
(file)
--- a/
toolchain/gcc/common.mk
+++ b/
toolchain/gcc/common.mk
@@
-180,6
+180,7
@@
endif
GCC_MAKE:= \
export SHELL="$(BASH)"; \
$(MAKE) \
+ CFLAGS="$(HOST_CFLAGS)" \
CFLAGS_FOR_TARGET="$(TARGET_CFLAGS)" \
CXXFLAGS_FOR_TARGET="$(TARGET_CFLAGS)"