[package] libjpeg: fix parallel build
authorFlorian Fainelli <florian@openwrt.org>
Wed, 9 Feb 2011 20:36:27 +0000 (20:36 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 9 Feb 2011 20:36:27 +0000 (20:36 +0000)
For parallel builds, make targets that build need to be separated from targets that install ;-)

Signed-off-by: Joe Roback <joe@roback.cc>
SVN-Revision: 25435

libs/jpeg/Makefile

index ab940ca612128219e4c3c04a4e5695911489e6fb..142bf9ac0f52622606ad6a0e24a84d605f13baf0 100644 (file)
@@ -57,7 +57,11 @@ define Build/Compile
        $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                prefix="$(PKG_INSTALL_DIR)/usr" \
                exec_prefix="$(PKG_INSTALL_DIR)/usr" \
-               all install install-headers install-lib
+               all
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               prefix="$(PKG_INSTALL_DIR)/usr" \
+               exec_prefix="$(PKG_INSTALL_DIR)/usr" \
+               install install-headers install-lib
 endef
 
 define Build/InstallDev