projects
/
openwrt
/
svn-archive
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
56613f0
)
curl: don't fail with empty TARGET_LDFLAGS
author
Jo-Philipp Wich
<jow@openwrt.org>
Wed, 18 Jan 2012 03:55:12 +0000
(
03:55
+0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Wed, 18 Jan 2012 03:55:12 +0000
(
03:55
+0000)
SVN-Revision: 29771
libs/curl/Makefile
patch
|
blob
|
history
diff --git
a/libs/curl/Makefile
b/libs/curl/Makefile
index 806192d0fd2a757451c38bee0bbbf65e816b05ba..6b3492c11aa06189c8df5a978eb970e913cfeecf 100644
(file)
--- a/
libs/curl/Makefile
+++ b/
libs/curl/Makefile
@@
-98,7
+98,7
@@
define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libcurl.{a,so*} $(1)/usr/lib/
$(CP) $(PKG_BUILD_DIR)/libcurl.pc $(1)/usr/lib/pkgconfig/
$(SED) 's,-L$$$${exec_prefix}/lib,,g' $(1)/usr/bin/curl-config
- $(
SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/libcurl.pc
+ $(
if $(TARGET_LDFLAGS),$(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/libcurl.pc)
ln -sf $(STAGING_DIR)/usr/bin/curl-config $(2)/bin/
endef