l7 protocols package
authorTim Yardley <lst@openwrt.org>
Tue, 31 Jul 2007 22:48:14 +0000 (22:48 +0000)
committerTim Yardley <lst@openwrt.org>
Tue, 31 Jul 2007 22:48:14 +0000 (22:48 +0000)
SVN-Revision: 8291

net/l7-protocols/Makefile [new file with mode: 0644]

diff --git a/net/l7-protocols/Makefile b/net/l7-protocols/Makefile
new file mode 100644 (file)
index 0000000..6366a35
--- /dev/null
@@ -0,0 +1,44 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=l7-protocols
+PKG_VERSION:=2007-07-27
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/l7-filter
+PKG_MD5SUM:=d007dd322e174a5c0ec722061ba8a57b
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/l7-protocols
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=Protocols for layer7 filtering
+  DESCRIPTION:=\
+       l7-filter classifies packets based on patterns in application \\\
+       layer data. This allows correct classification of P2P traffic that \\\
+       uses unpredictable ports as well as standard protocols running on \\\
+       non-standard ports.
+  URL:=http://l7-filter.sourceforge.net/
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/l7-protocols/install
+       $(INSTALL_DIR) $(1)/etc/l7-protocols
+       $(CP) $(PKG_BUILD_DIR)/example_traffic \
+               $(PKG_BUILD_DIR)/extra \
+               $(PKG_BUILD_DIR)/file_types \
+               $(PKG_BUILD_DIR)/groups.sh \
+               $(PKG_BUILD_DIR)/malware \
+               $(PKG_BUILD_DIR)/protocols \
+               $(PKG_BUILD_DIR)/testing \
+               $(1)/etc/l7-protocols
+endef
+
+$(eval $(call BuildPackage,l7-protocols))