upgrade to 7.36.0
authorImre Kaloz <kaloz@openwrt.org>
Wed, 26 Mar 2014 14:26:49 +0000 (14:26 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Wed, 26 Mar 2014 14:26:49 +0000 (14:26 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 40024

libs/curl/Makefile
libs/curl/patches/100-check_long_long.patch
libs/curl/patches/300-polarssl_compat.patch [deleted file]
libs/curl/patches/400-hugehelp.patch [new file with mode: 0644]

index 4ec9fb4b735dfced89c1681d09b6edfea294a7aa..d1a8fc5597c1ad7d4a7705a028ed95ca20591659 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.35.0
+PKG_VERSION:=7.36.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -18,7 +18,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
        ftp://ftp.planetmirror.com/pub/curl/ \
        http://www.mirrormonster.com/curl/download/ \
        http://curl.mirrors.cyberservers.net/download/
-PKG_MD5SUM:=c18fbdd031adb0529ae09fce399f2d10
+PKG_MD5SUM:=e6d1f9d1b59da5062109ffe14e0569a4
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
index 863a66a0ffa01c04df0aa51256c6f2c6a0c4825f..1285fa9581fedf31bbee335018667d6c95f47e54 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2898,6 +2898,7 @@ CURL_VERIFY_RUNTIMELIBS
+@@ -2901,6 +2901,7 @@ CURL_VERIFY_RUNTIMELIBS
  
  AC_CHECK_SIZEOF(size_t)
  AC_CHECK_SIZEOF(long)
diff --git a/libs/curl/patches/300-polarssl_compat.patch b/libs/curl/patches/300-polarssl_compat.patch
deleted file mode 100644 (file)
index 47b600f..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/lib/urldata.h
-+++ b/lib/urldata.h
-@@ -117,6 +117,9 @@
- #include <polarssl/entropy.h>
- #include <polarssl/ctr_drbg.h>
- #endif /* POLARSSL_VERSION_NUMBER<0x01010000 */
-+#if POLARSSL_VERSION_NUMBER>=0x01030000
-+#include <polarssl/compat-1.2.h>
-+#endif
- #endif /* USE_POLARSSL */
- #ifdef USE_CYASSL
---- a/lib/vtls/polarssl.c
-+++ b/lib/vtls/polarssl.c
-@@ -37,6 +37,10 @@
- #include <polarssl/x509.h>
- #include <polarssl/version.h>
-+#if POLARSSL_VERSION_NUMBER >= 0x01030000
-+#include <polarssl/compat-1.2.h>
-+#endif
-+
- #if POLARSSL_VERSION_NUMBER >= 0x01000000
- #include <polarssl/error.h>
- #endif /* POLARSSL_VERSION_NUMBER >= 0x01000000 */
-@@ -311,8 +315,8 @@ polarssl_connect_step1(struct connectdat
-                    &connssl->crl,
-                    conn->host.name);
--  ssl_set_own_cert(&connssl->ssl,
--                   &connssl->clicert, &connssl->rsa);
-+  ssl_set_own_cert_rsa(&connssl->ssl,
-+                       &connssl->clicert, &connssl->rsa);
-   if(!Curl_inet_pton(AF_INET, conn->host.name, &addr) &&
- #ifdef ENABLE_IPV6
diff --git a/libs/curl/patches/400-hugehelp.patch b/libs/curl/patches/400-hugehelp.patch
new file mode 100644 (file)
index 0000000..312792b
--- /dev/null
@@ -0,0 +1,13 @@
+--- a/src/tool_hugehelp.h
++++ b/src/tool_hugehelp.h
+@@ -23,6 +23,10 @@
+  ***************************************************************************/
+ #include "tool_setup.h"
++#ifdef USE_MANUAL
+ void hugehelp(void);
++#else
++#define hugehelp() Curl_nop_stmt
++#endif
+ #endif /* HEADER_CURL_TOOL_HUGEHELP_H */