projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
0a410df
)
netfilter: enable CONFIG_NF_CONNTRACK_MARK from kmod-nf-conntrack
author
Jo-Philipp Wich
<jo@mein.io>
Sun, 14 Jan 2018 19:06:07 +0000
(20:06 +0100)
committer
Jo-Philipp Wich
<jo@mein.io>
Tue, 16 Jan 2018 18:39:08 +0000
(19:39 +0100)
Unconditionally enable connmark support and tie it to the conntrack core
module to allow removing this kernel configuration dependency from the
xtables-addons package.
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/kernel/linux/modules/netfilter.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/netfilter.mk
b/package/kernel/linux/modules/netfilter.mk
index 0d817ed7f4eb73dd211fce29506e0d867e763d5c..f45845750075f01f3a51a01a2fa657ce664560cf 100644
(file)
--- a/
package/kernel/linux/modules/netfilter.mk
+++ b/
package/kernel/linux/modules/netfilter.mk
@@
-68,6
+68,7
@@
define KernelPackage/nf-conntrack
KCONFIG:= \
CONFIG_NETFILTER=y \
CONFIG_NETFILTER_ADVANCED=y \
+ CONFIG_NF_CONNTRACK_MARK=y \
CONFIG_NF_CONNTRACK_ZONES=y \
$(KCONFIG_NF_CONNTRACK)
FILES:=$(foreach mod,$(NF_CONNTRACK-m),$(LINUX_DIR)/net/$(mod).ko)